Home > Articles > Implementing Frame Mode MPLS

Implementing Frame Mode MPLS

Chapter Description

This chapter covers configuring Cisco Express Forwarding, verifying CEF, troubleshooting CEF, configuring MPLS on a Frame Mode interface, and configuring MTU size in label switching.

Configuration Example: Configuring Frame Mode MPLS

Figure 3-1 shows the network topology for the configuration that follows, which shows how to configure Frame Mode MPLS using commands covered in this chapter.

Figure 3-1

Figure 3-1 Network Topology for Frame Mode MPLS Configuration Example

R1 Router

Router>enable

Moves to privileged mode

Router#configure terminal

Moves to global configuration mode

Router(config)#hostname R1

Assigns hostname to router

R1(config)#ip cef

Enables CEF on device (enabled by default)

R1(config)#mpls ip

Enables MPLS globally on device (enabled by default)

R1(config)#interface loopback 0

Moves to interface configuration mode

R1(config-if)#ip address 172.16.1.1 255.255.255.0

Assigns IP address and netmask

R1(config-if)#interface fastethernet 0/0

Moves to interface configuration mode

R1(config-if)#ip address 172.16.10.1 255.255.255.0

Assigns IP address and netmask

R1(config-if)#mpls ip

Enables MPLS on this interface

R1(config-if)#mpls mtu 1508

Changes the maximum size of the packet allowed on this interface to 1508 bytes

R1(config-if)#no shutdown

Activates interface

R1(config-if)#exit

Returns to global configuration mode

R1(config)#router eigrp 1

Enables the EIGRP routing process for AS 1

R1(config-router)#network 172.16.0.0

Specifies which network to advertise in EIGRP

R1(config-router)#no auto-summary

Turns off the auto-summarization feature

R1(config-router)#exit

Returns to global configuration mode

R1(config)#exit

Returns to privileged mode

R1#copy running-config startup-config

Saves configuration in NVRAM

R2 Router

Router>enable

Moves to privileged mode

Router#configure terminal

Moves to global configuration mode

Router(config)#hostname R2

Assigns hostname to router

R2(config)#ip cef

Enables CEF on device (enabled by default)

R2(config)#mpls ip

Enables MPLS globally on device (enabled by default)

R2(config)#interface loopback 0

Moves to interface configuration mode

R2(config-if)#ip address 172.16.2.1 255.255.255.0

Assigns IP address and netmask

R2(config-if)#interface fastethernet 0/0

Moves to interface configuration mode

R2(config-if)#ip address 172.16.10.2 255.255.255.0

Assigns IP address and netmask

R2(config-if)#mpls ip

Enables MPLS on this interface

R2(config-if)#mpls mtu 1508

Changes the maximum size of the packet allowed on this interface to 1508 bytes

R2(config-if)#no shutdown

Activates interface

R2(config-if)#interface serial 0/0/0

Moves to interface configuration mode

R2(config-if)#ip address 172.16.20.5 255.255.255.252

Assigns IP address and netmask

R2(config-if)#mpls ip

Enables MPLS on this interface

R2(config-if)#clock rate 64000

Enables clock rate for this interface

R2(config-if)#no shutdown

Activates interface

R2(config-if)#exit

Returns to global configuration mode

R2(config)#router eigrp 1

Enables the EIGRP routing process for AS 1

R2(config-router)#network 172.16.0.0

Specifies which network to advertise in EIGRP

R2(config-router)#no auto-summary

Turns off the auto-summarization feature

R2(config-router)#exit

Returns to global configuration mode

R2(config)#exit

Returns to privileged mode

R2#copy running-config startup-config

Saves configuration in NVRAM

R3 Router

Router>enable

Moves to privileged mode

Router#configure terminal

Moves to global configuration mode

Router(config)#hostname R3

Assigns hostname to router

R3(config)#ip cef

Enables CEF on device (enabled by default)

R3(config)#mpls ip

Enables MPLS globally on device (enabled by default)

R3(config)#interface loopback 0

Moves to interface configuration mode

R3(config-if)#ip address 172.16.3.1 255.255.255.0

Assigns IP address and netmask

R3(config-if)#interface serial 0/0/0

Moves to interface configuration mode

R3(config-if)#ip address 172.16.20.6 255.255.255.252

Assigns IP address and netmask

R3(config-if)#mpls ip

Enables MPLS on this interface

R3(config-if)#no shutdown

Activates interface

R3(config-if)#exit

Returns to global configuration mode

R3(config)#router eigrp 1

Enables the EIGRP routing process for AS 1

R3(config-router)#network 172.16.0.0

Specifies which network to advertise in EIGRP

R3(config-router)#no auto-summary

Turns off the auto-summarization feature

R3(config-router)#exit

Returns to global configuration mode

R3(config)#exit

Returns to privileged mode

R3#copy running-config startup-config

Saves configuration in NVRAM