Home > Articles > Cisco Network Technology > IP Communications/VoIP > Cisco OSPF Route Redistribution

Cisco OSPF Route Redistribution

14-6: redistribute routing-process process-id route-map route-map-name

Syntax Description:

  • routing-process—Routing process to redistribute into OSPF. The routing process can be BGP, Connected, EGP, EIGRP, IGRP, ISIS, ISO-IGRP, Mobile, ODR, OSPF, RIP, or Static.

  • process-id—The process ID of the routing process (if applicable).

  • route-map-name—Name of the route map used to control which routes are redistributed or to set the parameters of the redistributed routes (metric, metric-type, or tag).

Purpose: To control the redistribution of routes learned from another routing process into OSPF. Redistributed routes become OSPF external type 2 routes by default. The default cost or metric of a redistributed route is 1 for BGP and 20 for all other protocols. This command will redistribute classful routes into OSPF only if the subnets keyword is not used. There are three general types of classful routes:

  • A Class A address with an 8-bit mask

  • A Class B address with a 16-bit mask

  • A Class C address with a 24-bit mask

You can use the subnets keyword to redistribute all routes. You can also use the metric, metric-type, and tag keywords. These values can also be set in the route map as shown in the examples covered in this section.

Initial Cisco IOS Software Release: 10.0

Configuration Example 6: Controlling the Routes to Be Redistributed Based on IP Address

In Figure 14-3, Router B is receiving six routes from Router C via EIGRP. Three of the EIGRP routes are classful (5.0.0.0/8, 145.5.0.0/16, 205.5.5.0/24) and three are classless (6.0.0.0/12, 146.6.0.0/20, 206.6.6.0/28). For this example, only the classless routes will be redistributed. Before redistributing the EIGRP routes into OSPF on Router B, configure the routers as shown in the listing that follows.

Figure 14-3Figure 14-3 A Route Map Is Needed to Control Which Routes Are Redistributed into OSPF from EIGRP

Router A¬
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Serial0/1
 ip address 10.1.1.1 255.255.255.252
 clockrate 64000
!
router ospf 1
 network 10.1.1.0 0.0.0.3 area 0
Router B
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 10.1.1.2 255.255.255.252
!
interface Serial 1
 ip address 10.1.1.5 255.255.255.252
!
router eigrp 1
 network 10.0.0.0
!
router ospf 1
 network 10.1.1.0 0.0.0.3 area 0
Router C
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
 ip address 5.5.5.5 255.0.0.0
!
interface Loopback2
 ip address 6.6.6.6 255.240.0.0
!
interface Loopback3
 ip address 145.5.5.5 255.255.0.0
!
interface Loopback4
 ip address 146.6.6.6 255.255.240.0
!
interface Loopback5
 ip address 205.5.5.5 255.255.255.0
!
interface Loopback6
 ip address 206.6.6.6 255.255.255.240
!
interface Serial0
 ip address 10.1.1.6 255.255.255.252
!
router eigrp 1
 network 5.0.0.0
 network 6.0.0.0
 network 10.0.0.0
 network 145.5.0.0
 network 146.6.0.0
 network 205.5.5.0
 network 206.6.6.0
 no auto-summary

Verify that Routers A and B have established an OSPF neighbor relationship.

rtrA#show ip ospf neighbor
Neighbor ID   Pri  State      Dead Time  Address     Interface
2.2.2.2             1   FULL/ -    00:00:36      10.1.1.2      Serial0/1

Verify that Routers B and C have formed an EIGRP neighbor relationship.

rtrB#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address         Interface  Hold Uptime  SRTT  RTO Q Seq
                                   (sec)                  (ms)                Cnt Num
0  10.1.1.6        Se1      11   00:25:42   308       2280       0    4

Verify that Router B is receiving the six EIGRP routes from Router C.

rtrB#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    U - per-user static route, o - ODR
Gateway of last resort is not set
   2.0.0.0/32 is subnetted, 1 subnets
C    2.2.2.2 is directly connected, Loopback0
D  205.5.5.0/24 [90/40640000] via 10.1.1.6, 00:26:25, Serial1
   206.6.6.0/28 is subnetted, 1 subnets
D    206.6.6.0 [90/40640000] via 10.1.1.6, 00:26:25, Serial1
D  5.0.0.0/8 [90/40640000] via 10.1.1.6, 00:26:25, Serial1
   6.0.0.0/12 is subnetted, 1 subnets
D    6.0.0.0 [90/40640000] via 10.1.1.6, 00:26:25, Serial1
D  145.5.0.0/16 [90/40640000] via 10.1.1.6, 00:26:25, Serial1
   10.0.0.0/30 is subnetted, 2 subnets
C    10.1.1.0 is directly connected, Serial0
C    10.1.1.4 is directly connected, Serial1
   146.6.0.0/20 is subnetted, 1 subnets
D    146.6.0.0 [90/40640000] via 10.1.1.6, 00:26:27, Serial1

Modify the configuration on Router B to redistribute only the classless EIGRP routes into OSPF.

Router B
router ospf 1
 redistribute eigrp 1 subnets route-map control-eigrp
!
access-list 1 permit 6.0.0.0 0.15.255.255
access-list 1 permit 146.6.0.0 0.0.15.255
access-list 1 permit 206.6.6.0 0.0.0.15
access-list 1 permit 10.1.1.4 0.0.0.3
route-map control-eigrp permit 10
 match ip address 1

Verification

Verify that only the classless EIGRP routes have been redistributed into OSPF.

rtrA#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route
Gateway of last resort is not set
   1.0.0.0/32 is subnetted, 1 subnets
C    1.1.1.1 is directly connected, Loopback0
   206.6.6.0/28 is subnetted, 1 subnets
O E2  206.6.6.0 [110/20] via 10.1.1.2, 00:02:05, Serial0/1
   6.0.0.0/12 is subnetted, 1 subnets
O E2  6.0.0.0 [110/20] via 10.1.1.2, 00:02:05, Serial0/1
10.0.0.0/30 is subnetted, 1 subnets
C    10.1.1.0 is directly connected, Serial0/1
   146.6.0.0/20 is subnetted, 1 subnets
O E2  146.6.0.0 [110/20] via 10.1.1.2, 00:02:06, Serial0/1
O E2  10.1.1.4 [110/200] via 10.1.1.2, 00:02:06, Serial0/1
7. Configuration Example 7: Modifying the Metric of Redistributed Routes Using a Route Map | Next Section Previous Section