Home > Articles > Cisco Certification > CCIE > CCIE Practical Studies: Configuring Route-Maps and Policy-based Routing

CCIE Practical Studies: Configuring Route-Maps and Policy-based Routing

  • Sample Chapter is provided courtesy of Cisco Press.
  • Date: Nov 26, 2003.

Chapter Description

Route maps are like duct tape for the network—they can be applied to numerous situations to address many issues. At times, they may not be the most "pretty solutions," but they will be very effective. Karl Solie and Leah Lynch show you how to configure and use route maps.

Lab 3: Configuring Complex Route Maps and Using Tags—Part II

Lab Walkthrough

Configure the Frame Relay switch and attach the three routers in a back-to-back fashion to the frame switch. Use V.35 cables to connect the routers. Create the four Ethernet LANs by the use of switches or hubs, as illustrated in Figure 2-11.

After the physical connections are complete, assign IP addresses to all LAN and WAN interfaces as depicted in Figure 2-11. Configure a Frame Relay point-to-point network between the gamenet and wisconsin_x routers and between the gamenet and california_x routers. Use the data-link connection identifiers (DLCIs) from the diagram. Example 2-36 lists the Frame Relay configuration of the gamenet, wisonsin_x, and california_x routers.

Example 2-36 Frame Relay Configurations for gamenet, wisonsin_x and california_x

hostname gamenet
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 ip address 192.168.1.5 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 102
!
interface Serial0.2 point-to-point
 ip address 192.168.1.9 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 302
hostname wisconsin_x
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial1/0.1 point-to-point
 ip address 192.168.1.6 255.255.255.252
 frame-relay interface-dlci 101

---------------------------------------------------

hostname california_x
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
!
interface Serial0/0.1 point-to-point
 ip address 192.168.1.10 255.255.255.252
 frame-relay interface-dlci 206

After configuring all the LAN and WAN interfaces, assign IP addresses and verify local connectivity. All routers should be able to ping their adjacent routers. For instance, unreal, wisconsin_x, and halo should all be able to ping the others' Ethernet address. When local connectivity is verified, you can begin to configure routing protocols.

Before attempting to control routing updates and writing route maps, confirm that you have IP connectivity across the network, redistributing all routes freely without filters. By so confirming, you can avoid troubleshooting route maps when the problem may be related to route redistribution or other problems with the routing protocols.

Begin by configuring the EIGRP domain between the wisconsin_x, unreal, and halo routers. The configuration of EIGRP on these three routers is rather straightforward. On the wisconsin_x router, you need a network statement and a default-metric because you need to redistribute OSPF into EIGRP. Example 2-37 lists the EIGRP configuration of the wisconsin_x router.

Example 2-37 EIGRP Configuration for wisonsin_x

hostname wisconsin_x
!
router eigrp 2002
 redistribute ospf 2002
 network 192.168.64.0
 default-metric 1000 100 254 1 1500
 no auto-summary

The EIGRP configuration on the unreal and halo routers will be identical. In Example 2-38, the EIGRP configuration demonstrates the two ways to configure the network for EIGRP. In Cisco IOS Software Release 12.1, EIGRP supports a wildcard mask with the network statement. Network 172.16.11.0 is using this method of configuration, and this example is following the standard way to configure EIGRP for the 192 networks. This is done purely for educational proposes.

Example 2-38 EIGRP Configuration of the unreal and halo Routers

!
hostname unreal
!
router eigrp 2002
 network 172.16.11.0 0.0.0.255
 network 192.168.64.0
 no auto-summary
 eigrp log-neighbor-changes
!

hostname halo
!
router eigrp 2002
 network 172.16.6.0 0.0.0.255
 network 192.168.64.0
 no auto-summary
 eigrp log-neighbor-changes

Then you configure OSPF and EIGRP on the gamenet router. The autonomous system ID used for EIGRP is 65001. The only interface sending EIGRP updates is interface s0.2, 192.168.1.9. The interface S0.1 is in OSPF area 2, and interface E0 is in OSPF area 0. Example 2-39 lists the OSPF and EIGRP configuration on the gamenet router. At this time, no route maps have been configured on any routers.

Example 2-39 EIGRP and OSPF Configuration of gamenet

hostname gamenet
!
router eigrp 65001
 redistribute ospf 2002
 passive-interface Ethernet0
 passive-interface Serial0.1
 network 192.168.1.0
 default-metric 1000 100 254 1 1500
 no auto-summary
!
router ospf 2002
 redistribute eigrp 65001 subnets
 network 192.168.1.5 0.0.0.0 area 2
 network 192.168.5.0 0.0.0.255 area 0
 default-metric 100
!

The california_x router will be configured for EIGRP with an autonomous system ID of 65001. Example 2-40 lists the EIGRP configuration of the california_x router.

Example 2-40 EIGRP Configuration of the california_x Router

hostname california_x
!
router eigrp 65001
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
! 

After configuring routing protocols on all the routers, verify IP connectivity with standard ping tests. Be sure the california_x router can ping the gamenet LAN and the halo and unreal routers. Ensure that the loopback networks are advertised and reachable by the unreal and halo routers. Do not attempt to write route maps for filters and such without first verifying IP reachability.

The lab instructions call for you to write a route map to tag the routes from the halo router with a tag of 100, and to tag the routes from the unreal router with a tag of 10. You will also tag route 192.168.64.0/24 with a tag of 100. Therefore, on the wisconsin_x router, you will write a route map to accomplish this during redistribution.

Following the five-step process for configuring route maps, you will begin by first configuring the route map with its associated match and set commands. The route map, called set_tag, will match routes using the match ip route-source command. Routes from the source IP address of 192.168.64.11, the unreal router, will have the tag set to 10. Routes from the source IP address of 192.168.64.6, the halo router, will have the tag set to 100. Routes from this source will also have the metric set to be an OSPF type 1 metric. Example 2-41 lists the syntax for the route map on the wisconsin_x router.

Example 2-41 Route-map set_tag Configuration on the wisconsin_x Router

hostname wisconsin_x
!
route-map set_tag permit 10 _First route-map instance
 match ip route-source 1  _Match ACL 1, 192.168.64.11
 set tag 10     _Set tag to 10
!
route-map set_tag permit 20 _Second route-map instance
 match ip route-source 2  _Match ACL 2, 192.168.64.6
 set metric-type type-1  _Set route type to Ext OSPF type-1 
 set tag 100     _Set tag to 100
!
route-map set_tag permit 30 _Third route-map instance
 match ip address 10   _Match ACL 10, all other routes
 set tag 100     _Set tag to 100
!

This now completes Steps 1 through 3 required to configure route maps. Now you apply the route maps. In this model, you apply the route map during redistribution of EIGRP into OSPF on the wisconsin_x router. Example 2-42 lists the complete configuration of the wisconsin_x router, including the ACLs.

Example 2-42 Configuration of the wisconsin_x Router

hostname wisconsin_x
!
<<<text omitted>>>
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay lmi-type cisco
!
interface Serial1/0.1 point-to-point
 ip address 192.168.1.6 255.255.255.252
 frame-relay interface-dlci 101
!
<<<text omitted>>>
!
interface Ethernet2/0
 ip address 192.168.64.3 255.255.255.0
!
router eigrp 2002
 redistribute ospf 2002    _redistribute OSPF
 network 192.168.64.0
 default-metric 1000 100 254 1 1500 _default metric
 no auto-summary
!
router ospf 2002
 redistribute eigrp 2002 subnets route-map set_tag _Redistribute and call route-map
 network 192.168.1.6 0.0.0.0 area 2
 default-metric 10         _default metric
!
access-list 1 permit 192.168.64.11     _match routes from 192.168.64.11
access-list 2 permit 192.168.64.6     _match routes from 192.168.64.6
access-list 10 permit any       _match all other routes/192.168.64.0
!
route-map set_tag permit 10       _route-map "set_tag" begins
 match ip route-source 1
 set tag 10
!
route-map set_tag permit 20
 match ip route-source 2
 set metric-type type-1
 set tag 100
!
route-map set_tag permit 30
 match ip address 10
 set tag 100

Another requirement of this model is to only redistribute routes, on the gamenet router, into EGIRP 65001 from OSPF with a tag value of 100, and to preserve this tag. You can do this by creating and applying a route map to the redistribution process that matches only routes with a tag of 100. You can use the match tag command for this purpose. Example 2-43 lists the required route map.

Example 2-43 Route Map match_tag100 on the gamenet Router

hostname gamenet
!
route-map match_tag100 permit 10  _begin route-map "match_tag100"
 match tag 100      _match the tag value of 100
 set tag 100       _set the tag for EIGRP.
!

The route map will be applied during redistribution from OSPF into EIGRP. Before you apply this route map, however, configure the last route map needed in the model.

The last requirement is to also prevent the private LAN, 10.0.101.0/24, from the california_x router, to be redistributed into OSPF from EIGRP on the gamenet router. You can prevent this with a route map applied during redistribution. The route map used to filter this subnet will call an ACL that matches only network 10.0.101.0/24. Example 2-44 lists the route map, called filter_net, used to filter network 10.0.101.0/24 and the associated ACL.

Example 2-44 Route Map filter_net on the gamenet Router

hostname gamenet
!
access-list 10 deny 10.0.101.0 0.0.0.255 _deny network 10.0.101.0/24
access-list 10 permit any     _Allow other networks to be redistributed
route-map filter_net permit 10    _begin route-map "filter_net"
 match ip address 10      _Match ACL 10

At this time, you can apply both route maps during the redistribution process. Example 2-45 lists the final configuration of the gamenet router.

Example 2-45 Final Configuration of the gamenet Router

hostname gamenet
!
 interface Ethernet0
 ip address 192.168.5.7 255.255.255.0
 no ip directed-broadcast
 media-type 10BaseT
!
<<<text omitted>>>
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 ip address 192.168.1.5 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 102
!
interface Serial0.2 point-to-point
 ip address 192.168.1.9 255.255.255.252
 no ip directed-broadcast
 frame-relay interface-dlci 302
!
router eigrp 65001
 redistribute ospf 2002 route-map match_tag100  _call route-map "match_tag100" 
 passive-interface Ethernet0
 passive-interface Serial0.1
 network 192.168.1.0
 default-metric 1000 100 254 1 1500     _set default metric
 no auto-summary
!
router ospf 2002
 redistribute eigrp 65001 subnets route-map filter_net _call route-map "filter_net"
 network 192.168.1.5 0.0.0.0 area 2
 network 192.168.5.0 0.0.0.255 area 0
 default-metric 100          _set default metric
!
access-list 10 deny 10.0.101.0 0.0.0.255
access-list 10 permit any
route-map filter_net permit 10
 match ip address 10
!
route-map match_tag100 permit 10
 match tag 100
 set tag 100 

To verify the configuration, ensure that the california_x router sees only the routes with a tag of 100, and that it can ping the 172.16.6.0/24 subnet but not the 172.16.11.0/24 subnet. Example 2-46 demonstrates the route table and the ping test on the california_x router.

Example 2-46 Verifying the Configuration on california_x

california_x# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
  U - per-user static route, o - ODR
Gateway of last resort is not set
  172.16.0.0/24 is subnetted, 1 subnets
D EX 172.16.6.0 [170/3097600] via 192.168.1.9, 02:47:46, Serial0/0.1
D EX 192.168.64.0/24 [170/3097600] via 192.168.1.9, 02:48:50, Serial0/0.1
  10.0.0.0/24 is subnetted, 2 subnets
C  10.0.100.0 is directly connected, Ethernet0/0
C  10.0.101.0 is directly connected, Ethernet0/1
  192.168.1.0/30 is subnetted, 2 subnets
C  192.168.1.8 is directly connected, Serial0/0.1
D  192.168.1.4 [90/2681856] via 192.168.1.9, 02:58:26, Serial0/0.1
california_x#
california_x# show ip route 172.16.6.0
Routing entry for 172.16.6.0/24
 Known via "eigrp 65001", distance 170, metric 3097600
Tag 100, type external
 Redistributing via eigrp 65001
 Last update from 192.168.1.9 on Serial0/0.1, 02:48:18 ago
 Routing Descriptor Blocks:
 * 192.168.1.9, from 192.168.1.9, 02:48:18 ago, via Serial0/0.1
  Route metric is 3097600, traffic share count is 1
  Total delay is 21000 microseconds, minimum bandwidth is 1000 Kbit
  Reliability 254/255, minimum MTU 1500 bytes
  Loading 1/255, Hops 1
california_x#
california_x# ping 172.16.6.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.6.6, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/34/36 ms
california_x# ping 172.16.11.11
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.11.11, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
california_x#

To verify that the private subnet, 10.0.101.0/24, is filtered from OSPF, you can view the route table of the wisconsin_x router, as demonstrated in Example 2-47.

Example 2-47 Final Route Table of the wisconsin_x Router

wisconsin_x# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
  * - candidate default, U - per-user static route, o - ODR
  P - periodic downloaded static route
Gateway of last resort is not set
  172.16.0.0/24 is subnetted, 2 subnets
D  172.16.11.0 [90/409600] via 192.168.64.11, 03:00:27, Ethernet2/0
D  172.16.6.0 [90/409600] via 192.168.64.6, 03:00:27, Ethernet2/0
C 192.168.64.0/24 is directly connected, Ethernet2/0
O IA 192.168.5.0/24 [110/58] via 192.168.1.5, 03:01:39, Serial1/0.1
  10.0.0.0/24 is subnetted, 1 subnets
O E2 10.0.100.0 [110/100] via 192.168.1.5, 03:01:03, Serial1/0.1
  192.168.1.0/30 is subnetted, 2 subnets
O E2 192.168.1.8 [110/100] via 192.168.1.5, 03:01:44, Serial1/0.1
C  192.168.1.4 is directly connected, Serial1/0.1
wisconsin_x#
4. Lab 4: Configuring Policy-Based Routing—Part I | Next Section Previous Section

Cisco Press Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Cisco Press and its family of brands. I can unsubscribe at any time.

Overview

Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Cisco Press products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information

To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@ciscopress.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information

Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security

Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children

This site is not directed to children under the age of 13.

Marketing

Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information

If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out

Users can always make an informed choice as to whether they should proceed with certain services offered by Cisco Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.ciscopress.com/u.aspx.

Sale of Personal Information

Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents

California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure

Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links

This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact

Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice

We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020