Troubleshooting EIGRP

Chapter Description

Learn how to quickly identify and fix the most common causes of EIGRP problems with these debugs, configurations, and useful show commands.

Troubleshooting EIGRP Route Summarization

Summarization is extremely important in a well-designed EIGRP network. Summarization is one of the few weapons to prevent stuck in active problems. Most summarization problems are the result of a misconfiguration of the router. Figure 7-29 shows a flowchart for troubleshooting an EIGRP summarization problem.

Figure 7-29Figure 7-29 Flowchart for Troubleshooting EIGRP Summarization Route Problem

EIGRP Summarization Route Problem—Cause: Subnetworks of Summary Route Don't Exist in Routing Table

Consider the case shown in Figure 7-30, in which Router A is configured to send out a summary route of 172.16.80.0 255.255.240.0 on its Ethernet 0 interface to Router B. Example 7-52 shows the configuration of Router A. However, the next-hop router is not seeing the route, and the 172.16.80.0 255.255.240.0 route is not in the router's topology table. Example 7-53 shows a snapshot of the router's routing table.

Figure 7-30Figure 7-30 Network Diagram for Case Study on EIGRP Summarization Route Problem

Example 7-52 Configuration of Router A in the Example Shown in Figure 7-30

Router_A#interface ethernet 0
ip address 192.168.3.1 255.255.255.0
ip summary-address EIGRP 1 172.16.80.0 255.255.240.0
interface Serial 0
ip address 192.168.1.2 255.255.255.0
interface Serial 1
ip address 192.168.2.2 255.255.255.0
router EIGRP 1
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0

Example 7-53 Routing Table Snapshot

Router A# show ip route 

C  192.168.1.0/24 is directly connected, Serial 0
C  192.168.2.0/24 is directly connected, Serial 1
C  192.168.3.0/24 is directly connected, Ethernet 0
D  172.16.99.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.97.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.79.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.70.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.103.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.76.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.98.0/24 [90/409600] via 192.168.1.1, Serial 0

In the configuration shown in Example 7-52, the summary route is configured to be 172.16.80.0 255.255.240.0 by using the command ip summary-address eigrp 1 172.16.80.0 255.255.240.0. This summary route covers the network address range from 172.16.80.0 to 172.16.95.255. From the routing table shown in Example 7-53, notice that no routes fit between the range of 172.16.80.0 to 172.16.95.255. Therefore, if no subnetworks of the configured summary route are present in the routing table, the router doesn't generate the summary route.

The solution to this problem is to configure an interface that falls in the 172.16.80.0 255.255.240.0 range. You can configure a loopback interface with address 172.16.81.1 255.255.255.0 to generate the summary route configured on Ethernet 0. Example 7-54 shows the changed configuration in Router A that will fix this manual-summarization problem.

Example 7-54 Changed Configuration of Router A to Fix the Manual-Summarization Problem

Router_A#
interface loopback 0
ip address 172.16.81.1 255.255.255.0
interface Ethernet 0
ip address 192.168.3.1 255.255.255.0
ip Summary-address EIGRP 1 172.16.80.0 255.255.240.0
interface Serial 0
ip address 192.168.1.2 255.255.255.0
Interface Serial 1
ip address 192.168.2.2 255.255.255.0
router EIGRP 1
network 172.16.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0

After the configuration change, the routing table on Router A shows the manual-summarization route of 172.16.80.0 255.255.240.0, as shown in Example 7-55.

Example 7-55 Routing Table Snapshot of Router A After the Configuration Change to Verify the Fix

Router A# show ip route 

C  192.168.1.0/24 is directly connected, Serial 0
C  192.168.2.0/24 is directly connected, Serial 1
C  192.168.3.0/24 is directly connected, Ethernet 0
C  172.16.81.1/24 is directly connected, Loopback 0
D  172.16.99.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.97.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.79.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.70.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.103.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.76.0/24 [90/409600] via 192.168.1.1, Serial 0
D  172.16.80.0/20 is a summary, 00:03:24, Null 0
D  172.16.98.0/24 [90/409600] via 192.168.1.1, Serial 0

EIGRP Summarization Route Problem—Cause: Too Much Summarization

Another EIGRP summarization route problem stems from when the summary route covers more subnetworks than exist. Figure 7-31 shows the network diagram to refer to for this case study.

Figure 7-31Figure 7-31 EIGRP Network Diagram—Too Much IP Address Summarization

As shown in Figure 7-31, Router B is connected to the network cloud with network of 172.16.1.0/24 through 172.16.15.0/24. Router B is summarizing those networks into one big summary route of 172.16.0.0/16 and sending it to Router A. Router A is connected to the core network, and Router A is sending Router B a default route of 0.0.0.0 0.0.0.0. The problem arises when a device in the core network tries to reach a network of 172.16.40.0/24, which is nonexistent in the network. When the device in the core network is trying to ping or traceroute to the 172.16.40.0 network, the packets are looping between Router A and Router B.

Example 7-56 shows Router A's routing table for 172.16.40.0.

Example 7-56 Router A Routing Table for 172.16.40.0

Router A# show ip route 172.16.40.0
Routing entry for 172.16.0.0/16
   Known via "EIGRP 1", distance 90, metric 409600,  type internal
Las
t update from 192.168.2.2 on Serial0
, 00:20:25 ago
   Routing Descriptor Blocks:
* 
192.168.2.2 from192.168.2.2, 00:20:25 ago, via Serial 0
   Route metric is 409600, traffic share count is 1
   Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
   Reliability 255/255, minimum MTU 1500 bytes
   Loading 1/255, Hops 1

The routing entry in Router A shows the summary route of 172.16.0.0/16 coming from Router B. Therefore, Router A forwards the packet to Router B. However, Router B sends the packet right back to Router A because Router B doesn't have the route for 172.16.40.0; it has only the default route pointing back to Router A. This causes the routing loop between Router A and Router B for any nonexistent network in the 172.16.0.0/16 range.

This problem is more of a design issue. The main issue is that Router B's summary route is too broad and includes nonexistent subnets. Also, Router A is sending a more general summary route (default route) to Router B. The solution is to have Router B send out only the summary route that covers the 172.16.1.0 through 172.16.15.0 networks. In other words, instead of sending the 172.16.0.0/16 summary route, Router B can send the 172.16.0.0 255.255.240.0 summary route to Router A. Therefore, when Router A tries to look at the routing table for the 172.16.40.0/24 entry, the routing table simply returns with % Network not in table message and drops the packet instead of sending it to Router B, which ends the loop.

6. Troubleshooting EIGRP Redistribution Problems | Next Section Previous Section