Troubleshooting EIGRP

  • Sample Chapter is provided courtesy of Cisco Press.
  • Date: Jul 26, 2002.

Chapter Description

Learn how to quickly identify and fix the most common causes of EIGRP problems with these debugs, configurations, and useful show commands.

Troubleshooting EIGRP Dial Backup Problem

Dial backup is a common setup on the remote access routers. When the primary link fails, dial backup provides another means of network connection. This section discusses EIGRP dial backup issues, in which the router doesn't disconnect the dialer interface when the primary link comes back. See the flowchart in Figure 7-35 for troubleshooting EIGRP dial-backup problems.

Figure 7-35Figure 7-35 Flowchart for Troubleshooting EIGRP Dial-Backup Problems

Figure 7-36 shows the network setup for the case study on the EIGRP dial backup problem.

Figure 7-36Figure 7-36 Network Susceptible to EIGRP Dial-Backup Problems

As Figure 7-36 illustrates, Router A and Router B are connected by a T1 line as the primary link. The ISDN backup serves as the backup link if the primary link fails. Example 7-67 shows the configurations for Routers A and B.

Example 7-67 Configurations for Routers A and B in Figure 7-36

Router A# isdn switch-type basic-5ess
interface ethernet 0
  ip address 172.16.1.1 255.255.255.128
interface serial 0
  ip address 172.16.2.1 255.255.255.0
  
  
interface bri 0
  ip address 172.16.3.1 255.255.255.0
  encapsulation ppp
  dialer map ip 172.16.3.2 name Router B broadcast 1234567
  ppp authentication chap
dialer-group 1
router EIGRP 1
  network 172.16.0.0
access-list 101 deny eigrp any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
ip route 172.16.4.0 255.255.255.128 172.16.3.2 200
Router B# isdn switch-type basic-5ess
interface ethernet 0
  ip address 172.16.4.1 255.255.255.128
interface serial 0
  ip address 172.16.2.2 255.255.255.0
interface bri 0
  ip address 172.16.3.2 255.255.255.0
  encapsulation ppp
  dialer map IP 172.16.3.1 name Router_A broadcast 3456789
  ppp authentication chap
dialer-group 1
router eigrp 1
  network 172.16.0.0
access-list 101 deny eigrp any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
ip route 172.16.1.0 255.255.255.128 172.16.3.1 200

From the configuration, the backup is done through the floating static route at the end of the configuration. When the primary interface (Serial 0) is down, the primary EIGRP route goes away and the floating static route is installed in the routing table that uses the BRI port. The dialer list is tied with access-list 101, which initiates the dial with any IP packet except for EIGRP hellos. This will not cause the BRI link to continuously dial because of EIGRP hello packets.

In this scenario, when the primary link goes down, the BRI link comes up and passes traffic because of the floating static route. The network administrator is trying to fix the link problem; in doing so, the network administrator reloaded Router B. When Router B came back up, the primary link also came up. The problem is that now even when the primary link came back up, the BRI link is still up and the traffic still is passing through BRI port.

On Router A, you must verify that the routing table entry for the interesting traffic is correct. Example 7-68 shows the output of show ip route 172.16.4.0 on Router A.

Example 7-68 Routing Table for 172.16.4.0

Router A# show ip route 172.16.4.0 

Routing entry for 172.16.4.0/25
 Known via "static", distance 200, metric 0
 Routing Descriptor Blocks:
 * 172.16.3.2
  Route metric is 0, traffic share count is 1

The output in Example 7-68 shows that Router A still is installing the floating static route to Router B's Ethernet network. The next step is to make sure that EIGRP neighbors are properly established between Router A and Router B over the primary interface. You can verify this with the show ip eigrp neighbor command, as demonstrated on both Router A and Router B in Example 7-69.

Example 7-69 Verifying an EIGRP Neighbor Relationship Between Routers A and B

Router A# show ip eigrp neighbor

IP-EIGRP neighbors for process 1
H  Address  Interface  Hold  Uptime  SRTT  RTO   Q  Seq
               (sec) (ms)            Cnt  Num
0  172.16.2.2 S0     12  00:10:23   21   200   0  23
1  172.16.3.2 BRI0    12   00:10:23   40   240   0  50  
Router B# show ip eigrp neighbor

IP-EIGRP neighbors for process 1
H  Address  Interface  Hold  Uptime  SRTT  RTO   Q  Seq
              (sec)  (ms)           Cnt  Num
0  172.16.2.1 S0     12  00:10:30   21  200    0   24
1  172.16.3.1 BRI0    12  00:10:30   40  240    0   51

The neighbor relationship looks fine from both routers. Both Routers A and B show that the neighbors are established without a problem. The next step is to look at the configuration on Router B to make sure that everything is configured properly. Example 7-70 shows Router B's configuration after reload.

Example 7-70 Router B Configuration After Reload

Router B# interface ethernet 0
  ip address 172.16.4.1 255.255.255.0
interface serial 0
  ip address 172.16.2.2 255.255.255.0
interface bri 0
  ip address 172.16.3.2 255.255.255.0
  encapsulation PPP
  dialer map IP 172.16.3.1 name Router A broadcast xxx
  ppp authentication chap
dialer-group 1
router eigrp 1
  network 172.16.0.0
access-list 101 deny eigrp any any
access-list 101 permit IP any any
dialer-list 1 protocol IP list 101
ip route 172.16.1.0 255.255.255.128 172.16.3.1 200

Notice that now, in Ethernet 0's configuration in Router B, the IP address is 172.16.4.1 255.255.255.0; the mask has changed from /25 to /24. This is the cause of the problem. When Router B advertises its Ethernet 0 route to Router A, it advertises the 172.16.4.0/24 route to Router A, and Router A still installs the floating static route of 172.16.4.0/25. The routing table shows the /25 route because it has a longer subnet mask. The wrong mask appears because when the network administrator reloaded Router B, Router B used the old configuration that it had stored, and Ethernet 0's old subnet mask a /24 before the network administrator changed it to /25. When the change is made, the network administrator didn't save the configuration.

The solution to this problem is to change the IP address subnet mask in Router B to the /25 subnet mask. Example 7-71 shows the configuration for Router B's Ethernet 0 interface.

Example 7-71 Properly Configuring the Subnet Mask for Router B's Ethernet 0 Interface

Router B# interface ethernet 0
  ip address 172.16.4.1 255.255.255.128

This change now causes Router B to send an EIGRP update of 172.16.4.0/25 to Router A, which causes Router A to use the EIGRP route instead of the floating static route. Example 7-72 shows what Router A's routing table now looks like.

Example 7-72 Routing Table for 172.16.4.0 on Router A After the Configuration Change in Example 7-71

Router A# show ip route 172.16.4.0 

Routing entry for 172.16.4.0/25
Known via "EIGRP 1", distance 90, metric 2195456, type internal
 Redistributing via eigrp 1
 
Last update from 172.16.2.2 on Serial 0
, 00:10:30 ago
 Routing Descriptor Blocks:
 * 172.16.2.2, from 172.16.2.2, 00:10:30 ago, via Serial 0
  Route metric is 2195456, traffic share count is 1
Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
Reliability 255/255, minimum MTU 1500 bytes
Loading 1/255, Hops 1

The traffic stops flowing to the BRI 0 interface and starts to flow to the primary link. The BRI interface then goes down and moves to backup mode again.

8. EIGRP Error Messages | Next Section Previous Section

Cisco Press Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Cisco Press and its family of brands. I can unsubscribe at any time.

Overview

Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Cisco Press products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information

To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@ciscopress.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information

Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security

Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children

This site is not directed to children under the age of 13.

Marketing

Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information

If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out

Users can always make an informed choice as to whether they should proceed with certain services offered by Cisco Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.ciscopress.com/u.aspx.

Sale of Personal Information

Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents

California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure

Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links

This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact

Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice

We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020