Home > Articles > Routing Concepts

Routing Concepts

  • Sample Chapter is provided courtesy of Cisco Press.
  • Date: Jan 1, 2018.

Chapter Description

This sample chapter from Routing and Switching Essentials v6 Companion Guide, answer the question, β€œWhat does a router do with a packet received from one network and destined for another network?” Details of the routing table will be examined, including connected, static, and dynamic routes.

Router Operation (1.3)

To make routing decisions, a router exchanges information with other routers. Alternatively, the router can also be manually configured on how to reach a specific network.

In this section you will explain how a router learns about remote networks when operating in a small to medium-sized business network.

Analyze the Routing Table (1.3.1)

The routing table is at the heart of making routing decisions. It is important that you understand the information presented in a routing table. In this topic, you will learn about routing table entries for directly connected networks.

The Routing Table (1.3.1.1)

The routing table of a router stores information about the following:

  • Directly connected routesThese routes come from the active router interfaces. Routers add a directly connected route when an interface is configured with an IP address and is activated.

  • Remote routesThese are remote networks connected to other routers. Routes to these networks can be either statically configured or dynamically learned through dynamic routing protocols.

Specifically, a routing table is a data file in RAM that stores route information about directly connected and remote networks. The routing table contains network or next-hop associations. These associations tell a router that a particular destination can be optimally reached by sending the packet to a specific router that represents the next hop on the way to the final destination. The next-hop association can also be the outgoing or exit interface to the next destination.

Figure 1-33 identifies the directly connected networks and remote networks of router R1.

Figure 1-33

Figure 1-33 Directly Connected and Remote Network Routes

Routing Table Sources (1.3.1.2)

On a Cisco router, the show ip route command is used to display the IPv4 routing table of a router. A router provides additional route information, including how the route was learned, how long the route has been in the table, and which specific interface to use to get to a predefined destination.

Entries in the routing table can be added as follows:

  • Local route interfacesAdded when an interface is configured and active. This entry is only displayed in IOS 15 or newer for IPv4 routes and all IOS releases for IPv6 routes.

  • Directly connected interfacesAdded to the routing table when an interface is configured and active.

  • Static routes—Added when a route is manually configured and the exit interface is active.

  • Dynamic routing protocol—Added when routing protocols that dynamically learn about the network, such as EIGRP and OSPF, are implemented and networks are identified.

The sources of the routing table entries are identified by a code. The code identifies how the route was learned. For instance, common codes include the following:

  • L—Identifies the address assigned to a router’s interface. This allows the router to efficiently determine when it receives a packet for the interface instead of being forwarded.

  • C—Identifies a directly connected network.

  • S—Identifies a static route created to reach a specific network.

  • D—Identifies a dynamically learned network from another router using EIGRP.

  • O—Identifies a dynamically learned network from another router using the OSPF routing protocol.

Example 1-14 shows the routing table for the R1 router in Figure 1-20.

Example 1-14 Routing Table for R1

R1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
      * - candidate default, U - per-user static route, o - ODR
        P - periodic downloaded static route

Gateway of last resort is not set
      10.0.0.0/24 is subnetted, 2 subnets
D        10.1.1.0/24 [90/2170112] via 209.165.200.226, 00:01:30, Serial0/0/0
D        10.1.2.0/24 [90/2170112] via 209.165.200.226, 00:01:30, Serial0/0/0
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, GigabitEthernet0/0
L        192.168.10.1/32 is directly connected, GigabitEthernet0/0
      192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.11.0/24 is directly connected, GigabitEthernet0/1
L        192.168.11.1/32 is directly connected, GigabitEthernet0/1
      209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        209.165.200.224/30 is directly connected, Serial0/0/0
L        209.165.200.225/32 is directly connected, Serial0/0/0
R1#

Remote Network Routing Entries (1.3.1.3)

As a network administrator, it is imperative to know how to interpret the content of IPv4 and IPv6 routing tables. Figure 1-34 displays an IPv4 routing table entry on R1 for the route to remote network 10.1.1.0.

Figure 1-34

Figure 1-34 Remote Network Entry Identifiers

Table 1-5 describes the parts of the routing table entry shown in Figure 1-34.

Table 1-5 Parts of a Remote Network Entry

Legend

Name

Description

A

Route Source

Identifies how the route was learned.

B

Destination Network

Identifies the IPv4 address of the remote network.

C

Administrative Distance

Identifies the trustworthiness of the route source.
Lower values indicate preferred route source.

D

Metric

Identifies the value assigned to reach the remote network. Lower values indicate preferred routes.

E

Next Hop

Identifies the IPv4 address of the next router to forward the packet to.

F

Route Timestamp

Identifies how much time has passed since the route was learned.

G

Outgoing Interface

Identifies the exit interface to use to forward a packet toward the final destination.

Directly Connected Routes (1.3.2)

In this topic you will learn how a router builds a routing table of directly connected networks.

Directly Connected Interfaces (1.3.2.1)

A newly deployed router, without configured interfaces, has an empty routing table, as shown in Example 1-15.

Example 1-15 Empty Routing Table

R1# show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R1#

Before the interface state is considered up/up and added to the IPv4 routing table, the interface must

  • Be assigned a valid IPv4 or IPv6 address

  • Be activated with the no shutdown command

  • Receive a carrier signal from another device (router, switch, host, and so on)

When the interface is up, the network of that interface is added to the routing table as a directly connected network.

Directly Connected Routing Table Entries (1.3.2.2)

An active, properly configured, directly connected interface actually creates two routing table entries. Figure 1-35 displays the IPv4 routing table entries on R1 for the directly connected network 192.168.10.0.

Figure 1-35

Figure 1-35 Directly Connected Network Entry Identifiers

The routing table entry for directly connected interfaces is simpler than the entries for remote networks. Table 1-6 describes the parts of the routing table entry shown in Figure 1-35.

Table 1-6 Parts of a Directly Connected Network Entry

Legend

Name

Description

A

Route Source

Identifies how the network was learned by the router.Directly connected interfaces have two route source codes. ‘C’ identifies a directly connected network. ‘L’ identifies the IPv4 address assigned to the router’s interface.

B

Destination Network

Identifies the destination network and how it is connected.

C

Outgoing Interface

Identifies the exit interface to use when forwarding packets to the destination network.

Directly Connected Examples (1.3.2.3)

Example 1-16 shows the steps to configure and activate the interfaces attached to R1 in Figure 1-20. Notice the Layer 1 and 2 informational messages generated as each interface is activated.

Example 1-16 Configuring the Directly Connected IPv4 Interfaces

R1(config)# interface gigabitethernet 0/0
R1(config-if)# description Link to LAN 1
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# exit
*Feb  1 13:37:35.035: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state
  to down
*Feb  1 13:37:38.211: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state
  to up
*Feb  1 13:37:39.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Gigabit
  Ethernet0/0, changed state to up
R1(config)#  interface gigabitethernet 0/1
R1(config-if)# description Link to LAN 2
R1(config-if)#  ip address 192.168.11.1 255.255.255.0
R1(config-if)#  no shutdown
R1(config-if)#  exit
*Feb  1 13:38:01.471: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state
  to down
*Feb  1 13:38:04.211: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state
  to up
*Feb  1 13:38:05.211: %LINEPROTO-5-UPDOWN: Line protocol on Interface Gigabit
  Ethernet0/1, changed state to up
R1(config)# interface serial 0/0/0
R1(config-if)# description Link to R1
R1(config-if)# ip address 209.165.200.225 255.255.255.252
R1(config-if)# clock rate 128000
R1(config-if)#  no shutdown
R1(config-if)# end
*Feb  1 13:38:22.723: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
*Feb  1 13:38:23.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0,
  changed state to up
R1#

As each interface is added, the routing table automatically adds the connected (‘C’) and local (‘L’) entries. Example 1-17 provides an example of the routing table with the directly connected interfaces of R1 configured and activated.

Example 1-17 Verifying the Directly Connected Routing Table Entries

R1# show ip route | begin Gateway
Gateway of last resort is not set

       192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C         192.168.10.0/24 is directly connected, GigabitEthernet0/0
L         192.168.10.1/32 is directly connected, GigabitEthernet0/0
       192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C         192.168.11.0/24 is directly connected, GigabitEthernet0/1
L         192.168.11.1/32 is directly connected, GigabitEthernet0/1
       209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C         209.165.200.224/30 is directly connected, Serial0/0/0
L         209.165.200.225/32 is directly connected, Serial0/0/0
R1#

Directly Connected IPv6 Example (1.3.2.4)

Example 1-18 shows the configuration steps for the directly connected interfaces of R1 in Figure 1-21 with the indicated IPv6 addresses. Notice the Layer 1 and Layer 2 informational messages generated as each interface is configured and activated.

Example 1-18 Configuring the Directly Connected IPv6 Interfaces

R1(config)# interface gigabitethernet 0/0
R1(config-if)# description Link to LAN 1
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
*Feb  3 21:38:37.279: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state
  to down
*Feb  3 21:38:40.967: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state
  to up
*Feb  3 21:38:41.967: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEther-
  net0/0, changed state to up
R1(config)# interface gigabitethernet 0/1
R1(config-if)# description Link to LAN 2
R1(config-if)# ipv6 address 2001:db8:acad:2::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
*Feb  3 21:39:21.867: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state
  to down
*Feb  3 21:39:24.967: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state
  to up
*Feb  3 21:39:25.967: %LINEPROTO-5-UPDOWN: Line protocol on Interface Gigabit
  Ethernet0/1, changed state to up
R1(config)# interface serial 0/0/0
R1(config-if)# description Link to R2
R1(config-if)# ipv6 address 2001:db8:acad:3::1/64
R1(config-if)# clock rate 128000
R1(config-if)# no shutdown
*Feb  3 21:39:43.307: %LINK-3-UPDOWN: Interface Serial0/0/0, changed state to down
R1(config-if)# end
R1#

The show ipv6 route command shown in Example 1-19 is used to verify that IPv6 networks and specific IPv6 interface addresses have been installed in the IPv6 routing table. Like IPv4, a ‘C’ next to a route indicates that this is a directly connected network. An ‘L’ indicates the local route. In an IPv6 network, the local route has a /128 prefix. Local routes are used by the routing table to efficiently process packets with a destination address of the interface of the router.

Example 1-19 Verifying IPv6 Routing Table

R1# show ipv6 route
IPv6 Routing Table - default - 5 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C   2001:DB8:ACAD:1::/64 [0/0]
     via GigabitEthernet0/0, directly connected
L   2001:DB8:ACAD:1::1/128 [0/0]
     via GigabitEthernet0/0, receive
C   2001:DB8:ACAD:2::/64 [0/0]
      via GigabitEthernet0/1, directly connected
L   2001:DB8:ACAD:2::1/128 [0/0]
     via GigabitEthernet0/1, receive
L  FF00::/8 [0/0]
    via Null0, receive
R1#

Notice that there is also a route installed to the FF00::/8 network. This route is required for multicast routing.

Example 1-20 displays how the show ipv6 route command can be combined with a specific network destination to display the details of how the router learned that route.

Example 1-20 Verifying a Single IPv6 Route Entry

R1# show ipv6 route 2001:db8:acad:1::/64
Routing entry for 2001:DB8:ACAD:1::/64
  Known via "connected", distance 0, metric 0, type connected
  Route count is 1/1, share count 0
  Routing paths:
    directly connected via GigabitEthernet0/0
      Last updated 03:14:56 ago

R1#

Example 1-21 displays how connectivity to R2 can be verified using the ping command. Notice what happens when the G0/0 LAN interface of R2 is the target of the ping command. The pings are unsuccessful. This is because R1 does not have an entry in the routing table to reach the 2001:DB8:ACAD:4::/64 network.

Example 1-21 Testing Connectivity to R2

R1# ping 2001:db8:acad:3::2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ACAD:3::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
R1# ping 2001:db8:acad:4::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ACAD:4::1, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)
R1#

R1 requires additional information to reach a remote network. Remote network route entries can be added to the routing table using either of the following:

  • Static routing

  • Dynamic routing protocols

Statically Learned Routes (1.3.3)

In this topic you will learn how a router builds a routing table using static routes.

Static Routes (1.3.3.1)

After directly connected interfaces are configured and added to the routing table, static or dynamic routing can be implemented.

Static routes are manually configured. They define an explicit path between two networking devices. Unlike a dynamic routing protocol, static routes are not automatically updated and must be manually reconfigured if the network topology changes. The benefits of using static routes include improved security and resource efficiency. Static routes use less bandwidth than dynamic routing protocols, and no CPU cycles are used to calculate and communicate routes. The main disadvantage to using static routes is the lack of automatic reconfiguration if the network topology changes.

There are two common types of static routes in the routing table:

  • Static route to a specific network

  • Default static route

A static route can be configured to reach a specific remote network. IPv4 static routes are configured using the following command:

Router(config)# ip route network mask { next-hop-ip | exit-intf }

A static route is identified in the routing table with the code ‘S.’

A default static route is similar to a default gateway on a host. The default static route specifies the exit point to use when the routing table does not contain a path for the destination network. A default static route is useful when a router has only one exit point to another router, such as when the router connects to a central router or service provider.

To configure an IPv4 default static route, use the following command:

Router(config)# ip route 0.0.0.0 0.0.0.0 { exit-intf | next-hop-ip }

Figure 1-36 provides a simple scenario of how default and static routes can be applied.

Figure 1-36

Figure 1-36 Static and Default Route Scenario

Static Route Examples (1.3.3.2)

Example 1-22 shows the configuration and verification of an IPv4 default static route on R1 from Figure 1-20. The static route is using Serial 0/0/0 as the exit interface. Notice that the configuration of the route generated an ‘S*’ entry in the routing table. The ‘S’ signifies that the route source is a static route, whereas the asterisk (*) identifies this route as a possible candidate to be the default route. In fact, it has been chosen as the default route as evidenced by the line that reads, “Gateway of Last Resort is 0.0.0.0 to network 0.0.0.0.”

Example 1-22 Configuring and Verifying a Default Static IPv4 Route

R1(config)# ip route 0.0.0.0 0.0.0.0 Serial0/0/0
R1(config)# exit
R1#
*Feb  1 10:19:34.483: %SYS-5-CONFIG_I: Configured from console by console
R1# show ip route | begin Gateway
Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S*    0.0.0.0/0 is directly connected, Serial0/0/0
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, GigabitEthernet0/0
L        192.168.10.1/32 is directly connected, GigabitEthernet0/0
      192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.11.0/24 is directly connected, GigabitEthernet0/1
L        192.168.11.1/32 is directly connected, GigabitEthernet0/1
      209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C        209.165.200.224/30 is directly connected, Serial0/0/0
L        209.165.200.225/32 is directly connected, Serial0/0/0
R1#

Example 1-23 shows the configuration and verification of two static routes from R2 to reach the two LANs on R1. The route to 192.168.10.0/24 has been configured using the exit interface while the route to 192.168.11.0/24 has been configured using the next-hop IPv4 address. Although both are acceptable, there are some differences in how they operate. For instance, notice how different they look in the routing table. Also notice that because these static routes were to specific networks, the output indicates that the Gateway of Last Resort is not set.

Example 1-23 Configuring and Verifying Static IPv4 Routes

R2(config)# ip route 192.168.10.0 255.255.255.0 s0/0/0
R2(config)# ip route 192.168.11.0 255.255.255.0 209.165.200.225
R2(config)# exit
R2#
R2# show ip route | begin Gateway
Gateway of last resort is not set

       10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C         10.1.1.0/24 is directly connected, GigabitEthernet0/0
L         10.1.1.1/32 is directly connected, GigabitEthernet0/0
C         10.1.2.0/24 is directly connected, GigabitEthernet0/1
L         10.1.2.1/32 is directly connected, GigabitEthernet0/1
S      192.168.10.0/24 is directly connected, Serial0/0/0
S      192.168.11.0/24 [1/0] via 209.165.200.225
       209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C         209.165.200.224/30 is directly connected, Serial0/0/0
L         209.165.200.226/32 is directly connected, Serial0/0/0
R2#

Static IPv6 Route Examples (1.3.3.3)

Like IPv4, IPv6 supports static and default static routes. They are used and configured like IPv4 static routes.

To configure a default static IPv6 route, use the ipv6 route ::/0 {ipv6-address | interface-type interface-number} global configuration command.

Example 1-24 shows the configuration and verification of a default static route on R1 from Figure 1-21. The static route is using Serial 0/0/0 as the exit interface.

Example 1-24 Configuring and Verifying a Default Static IPv6 Route

R1(config)# ipv6 route ::/0 s0/0/0
R1(config)# exit
R1# show ipv6 route
IPv6 Routing Table - default - 8 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S   ::/0 [1/0]
     via Serial0/0/0, directly connected
<output omitted>

Notice in the output that the default static route configuration generated an ‘S’ entry in the routing table. The ‘S’ signifies that the route source is a static route. Unlike the IPv4 static route, there is no asterisk (*) or Gateway of Last Resort explicitly identified.

Like IPv4, static routes are routes explicitly configured to reach a specific remote network. Static IPv6 routes are configured using the ipv6 route ipv6-prefix/prefix-length {ipv6-address|interface-type interface-number} global configuration command.

Example 1-25 shows the configuration and verification of two static routes from R2 to reach the two LANs on R1. The route to the 2001:0DB8:ACAD:2::/64 LAN is configured with an exit interface, whereas the route to the 2001:0DB8:ACAD:1::/64 LAN is configured with the next-hop IPv6 address. The next-hop IPv6 address can be either an IPv6 global unicast or a link-local address.

Example 1-25 Configuring and Verifying Static IPv6 Routes

R2(config)# ipv6 route 2001:DB8:ACAD:1::/64 2001:DB8:ACAD:3::1
R2(config)# ipv6 route 2001:DB8:ACAD:2::/64 s0/0/0
R2(config)# end
R2# show ipv6 route
IPv6 Routing Table - default - 9 entries
Codes:  C - Connected, L - Local, S - Static, U - Per-user Static route
        B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
        I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
        EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
        NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
        OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
S    2001:DB8:ACAD:1::/64 [1/0]
      via 2001:DB8:ACAD:3::1
S    2001:DB8:ACAD:2::/64 [1/0]
      via Serial0/0/0, directly connected
<output omitted>

Example 1-26 confirms remote network connectivity to the 2001:0DB8:ACAD:4::/64 LAN on R2 from R1.

Example 1-26 Verify Connectivity to Remote Network

R1# ping 2001:db8:acad:4::1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:DB8:ACAD:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/13/16 ms
R1#

Dynamic Routing Protocols (1.3.4)

In this topic you will learn how a router builds a routing table using dynamic routes.

Dynamic Routing (1.3.4.1)

Dynamic routing protocols are used by routers to share information about the reachability and status of remote networks. Dynamic routing protocols perform several activities, including network discovery and maintaining routing tables.

Network discovery is the ability of a routing protocol to share information about the networks that it knows about with other routers that are also using the same routing protocol. Instead of depending on manually configured static routes to remote networks on every router, a dynamic routing protocol allows the routers to automatically learn about these networks from other routers. These networks, and the best path to each, are added to the routing table of the router and identified as a network learned by a specific dynamic routing protocol.

During network discovery, routers exchange routes and update their routing tables. Routers have converged after they have finished exchanging and updating their routing tables. Routers then maintain the networks in their routing tables.

Figure 1-37 provides a simple scenario of how two neighboring routers would initially exchange routing information. In this simplified exchange, R1 introduces itself and the networks it can reach. R2 responds with its list of networks.

Figure 1-37

Figure 1-37 Dynamic Routing Scenario

IPv4 Routing Protocols (1.3.4.2)

A router running a dynamic routing protocol does not only make a best path determination to a network; it also determines a new best path if the initial path becomes unusable (or if the topology changes). For these reasons, dynamic routing protocols have an advantage over static routes. Routers that use dynamic routing protocols automatically share routing information with other routers and compensate for any topology changes without involving the network administrator.

Cisco routers can support a variety of dynamic IPv4 routing protocols, including these:

  • EIGRP—Enhanced Interior Gateway Routing Protocol

  • OSPF—Open Shortest Path First

  • IS-IS—Intermediate System-to-Intermediate System

  • RIP—Routing Information Protocol

To determine which routing protocols the IOS supports, use the router ? command in global configuration mode, as shown in Example 1-27.

Example 1-27 IPv4 Routing Protocols

R1(config)# router ?
  bgp       Border Gateway Protocol (BGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  ospfv3    OSPFv3
  rip       Routing Information Protocol (RIP)

R1(config)# router

IPv4 Dynamic Routing Examples (1.3.4.3)

In this dynamic routing example, assume that R1 and R2 have been configured to support the dynamic routing protocol EIGRP. R2 now has a connection to the Internet, as shown in Figure 1-38. The routers also advertise directly connected networks. R2 advertises that it is the default gateway to other networks.

Figure 1-38

Figure 1-38 IPv4 Topology with Connection to the Internet

The output in Example 1-28 displays the routing table of R1 after the routers have exchanged updates and converged.

Example 1-28 Verify Dynamic IPv4 Routes

R1# show ip route | begin Gateway

Gateway of last resort is 209.165.200.226 to network 0.0.0.0

D*EX 0.0.0.0/0 [170/2297856] via 209.165.200.226, 00:07:29, Serial0/0/0
     10.0.0.0/24 is subnetted, 2 subnets

D         10.1.1.0 [90/2172416] via 209.165.200.226, 00:07:29, Serial0/0/0
D         10.1.2.0 [90/2172416] via 209.165.200.226, 00:07:29, Serial0/0/0
       192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C         192.168.10.0/24 is directly connected, GigabitEthernet0/0
L         192.168.10.1/32 is directly connected, GigabitEthernet0/0
       192.168.11.0/24 is variably subnetted, 2 subnets, 2 masks
C         192.168.11.0/24 is directly connected, GigabitEthernet0/1
L         192.168.11.1/32 is directly connected, GigabitEthernet0/1
       209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C         209.165.200.224/30 is directly connected, Serial0/0/0
L         209.165.200.225/32 is directly connected, Serial0/0/0
R1#

Along with the connected and link-local interfaces, there are three ‘D’ entries in the routing table.

  • The entry beginning with ‘D*EX’ identifies that the source of this entry was EIGRP (‘D’). The route is a candidate to be a default route (‘*’), and the route is an external route (‘*EX’) forwarded by EIGRP.

  • The other two ‘D’ entries are routes installed in the routing table based on the update from R2 advertising its LANs.

IPv6 Routing Protocols (1.3.4.4)

ISR devices support the dynamic IPv6 routing protocols shown in Example 1-29.

Example 1-29 IPv6 Routing Protocols

R1(config)# ipv6 router ?
  eigrp      Enhanced Interior Gateway Routing Protocol (EIGRP)
  ospf       Open Shortest Path First (OSPF)
  rip        IPv6 Routing Information Protocol (RIPv6)

R1(config)# ipv6 router

Support for dynamic IPv6 routing protocols is dependent on hardware and IOS version. Most of the modifications in the routing protocols are to support the longer IPv6 addresses and different header structures.

IPv6 routing is not enabled by default. Therefore, to enable IPv6 routers to forward traffic, you must configure the ipv6 unicast-routing global configuration command.

IPv6 Dynamic Routing Examples (1.3.4.5)

Routers R1 and R2 in Figure 1-21 have been configured with the dynamic routing protocol EIGRP for IPv6. (This is the IPv6 equivalent of EIGRP for IPv4.)

To view the routing table on R1, enter the show ipv6 route command, as shown in Example 1-30.

Example 1-30 Verify Dynamic IPv6 Routes

R1# show ipv6 route
IPv6 Routing Table - default - 9 entries
Codes:  C - Connected, L - Local, S - Static, U - Per-user Static route
        B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
        I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
        EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
        NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
        OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
C    2001:DB8:ACAD:1::/64 [0/0]
      via GigabitEthernet0/0, directly connected
L    2001:DB8:ACAD:1::1/128 [0/0]
      via GigabitEthernet0/0, receive
C    2001:DB8:ACAD:2::/64 [0/0]
      via GigabitEthernet0/1, directly connected
L    2001:DB8:ACAD:2::1/128 [0/0]
      via GigabitEthernet0/1, receive
C    2001:DB8:ACAD:3::/64 [0/0]
      via Serial0/0/0, directly connected
L    2001:DB8:ACAD:3::1/128 [0/0]
      via Serial0/0/0, receive
D    2001:DB8:ACAD:4::/64 [90/2172416]
      via FE80::D68C:B5FF:FECE:A120, Serial0/0/0
D    2001:DB8:ACAD:5::/64 [90/2172416]
      via FE80::D68C:B5FF:FECE:A120, Serial0/0/0
L    FF00::/8 [0/0]
      via Null0, receive
R1#

The output shows the routing table of R1 after the routers have exchanged updates and converged. Along with the connected and local routes, there are two ‘D’ entries (EIGRP routes) in the routing table.

7. Summary (1.4) | Next Section Previous Section

There are currently no related articles. Please check back later.