Home > Articles > Cisco VoIP Implementations

Cisco VoIP Implementations

  • Sample Chapter is provided courtesy of Cisco Press.
  • Date: Jan 1, 2008.

Router Configuration

Using Figure 2-1 as a reference, the following shows the output of the show running-config and the output of the show flash: commands for the router in that diagram, which detail the configuration of CME.

Router# show running-config
!
version 12.4
!
hostname Router
!
clock timezone CST -6
clock summer-time CST recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
!
ip dhcp pool ITS
   import all
   network 192.168.30.0 255.255.255.0
   option 150 ip 192.168.31.1
   default-router 192.168.30.1
!
!
username roth privilege 15 secret 5 $some_passwordstring_this_long
!
!
interface Loopback0
 ip address 192.168.31.1 255.255.255.0
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
!
interface FastEthernet1/0
 ip address 192.168.30.1 255.255.255.0
 ip nat inside
!
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
ip nat inside source list 1 interface FastEthernet0/0 overload
!
access-list 23 permit 192.168.30.0 0.0.0.255
tftp-server flash:P00308000400.bin
!
!
telephony-service
 load 7960-7940 P00308000400
 max-ephones 8
 max-dn 4
 ip source-address 192.168.31.1 port 2000
 auto assign 1 to 4
max-conferences 4 gain -6
 moh music-on-hold.au
 transfer-system full-consult
 create cnf-files version-stamp 7960 Oct 09 2007 19:17:26
!
!
ephone-dn  1  dual-line
 number 5001
!
ephone-dn  2  dual-line
 number 5002
!
ephone-dn  3  dual-line
 number 5003
!
ephone-dn  4  dual-line
 number 5004
!
!
ephone 1
 no multicast-moh
 mac-address 0050.DA7C.AB03
 codec g729r8
 type CIPC
 button 1:1
!
ephone 2
 no multicast-moh
 mac-address 001A.4B61.F6C1
 codec g729r8
 type CIPC
 button 1:2
!
ephone  3
 no multicast-moh
!
ephone  4
 no multicast-moh
!
!
banner login #

   User Authentication Required

#
!
line con 0
 login local
line aux 0
 login local
line vty 0 4
 access-class 23 in
 login local
 transport input telnet
!
ntp clock-period 17208155
ntp server <IP of time server> source FastEthernet0/0 prefer
end

Router# show flash:

System flash directory:
File  Length   Name/status
  1   21086616  c1700-ipvoicek9-mz.124-15.T1.bin
  2   4627     admin_user.html
  3   653758   admin_user.js
  4   1029     CiscoLogo.gif
  5   618      CME_GUI_README.TXT
  6   953      Delete.gif
  7   16344    dom.js
  8   864      downarrow.gif
  9   6146     ephone_admin.html
 10   4658     logohome.gif
 11   3724     normal_user.html
 12   80033    normal_user.js
 13   1347     Plus.gif
 14   843      sxiconad.gif
 15   174      Tab.gif
 16   2410     telephony_service.html
 17   870      uparrow.gif
 18   9968     xml-test.html
 19   3412     xml.template
 20   129828   P00308000400.bin
 21   461      P00308000400.loads
 22   701768   P00308000400.sb2
 23   130232   P00308000400.sbn
 24   496521   music-on-hold.au
[23338772 bytes used, 9953512 available, 33292284 total]
32768K bytes of processor board System flash (Read/Write)

There are currently no related articles. Please check back later.