Home > Articles > Implementing Inter-VLAN Routing

Implementing Inter-VLAN Routing

Chapter Description

The CCNP and CCIE Enterprise Core & CCNP Enterprise Advanced Routing Portable Command Guide is a fully updated quick reference resource to help you memorize commands and concepts for CCNP or CCIE certifications. In this sample chapter, you will review information and commands related to implementing inter-VLAN routing.

Configuration Example: Inter-VLAN Communication

Figure 3-1 illustrates the network topology for the configuration that follows, which shows how to configure inter-VLAN communication using commands covered in this chapter. Some commands used in this configuration are from other chapters.

Figure 3-1

Figure 3-1 Network Topology for Inter-VLAN Communication Configuration

ISP Router

Router> enable

Moves to privileged EXEC mode

Router># configure terminal

Moves to global configuration mode

Router(config)# hostname ISP

Sets the host name

ISP(config)# interface loopback 0

Moves to interface configuration mode

ISP(config-if)# description
simulated address representing
remote website

Sets the locally significant interface description

ISP(config-if)# ip address
198.133.219.1 255.255.255.0

Assigns an IP address and netmask

ISP(config-if)# interface serial
0/0/0

Moves to interface configuration mode

ISP(config-if)# description WAN
link to the Corporate Router

Sets the locally significant interface description

ISP(config-if)# ip address
192.31.7.5 255.255.255.252

Assigns an IP address and netmask

ISP(config-if)# clock
rate 4000000

Assigns a clock rate to the interface; DCE cable is plugged into this interface

ISP(config-if)# no shutdown

Enables the interface

ISP(config-if)# exit

Returns to global configuration mode

ISP(config-if)# router
eigrp 10

Creates Enhanced Interior Gateway Routing Protocol (EIGRP) routing process 10

ISP(config-router)# network
198.133.219.0 0.0.0.255

Advertises directly connected networks

ISP(config-router)# network
192.31.7.0 0.0.0.255

Advertises directly connected networks

ISP(config-router)# end

Returns to privileged EXEC mode

ISP# copy running-config
startup-config

Saves the configuration to NVRAM

CORP Router

Router> enable

Moves to privileged EXEC mode

Router># configure terminal

Moves to global configuration mode

Router(config)# hostname CORP

Sets the host name

CORP(config)# no ip
domain-lookup

Turns off Domain Name System (DNS) resolution to avoid wait time due to DNS lookup of spelling errors

CORP(config)# interface serial
0/0/0

Moves to interface configuration mode

CORP(config-if)# description
link to ISP

Sets the locally significant interface description

CORP(config-if)# ip address
192.31.7.6 255.255.255.252

Assigns an IP address and netmask

CORP(config-if)# no shutdown

Enables the interface

CORP(config)# interface
fastethernet 0/1

Moves to interface configuration mode

CORP(config-if)# description
link to L3Switch1

Sets the locally significant interface description

CORP(config-if)# ip address
172.31.1.5 255.255.255.252

Assigns an IP address and netmask

CORP(config-if)# no shutdown

Enables the interface

CORP(config-if)# exit

Returns to global configuration mode

CORP(config)# interface
fastethernet 0/0

Enters interface configuration mode

CORP(config-if)# no shutdown

Enables the interface

CORP(config-if)# interface
fastethernet 0/0.1

Creates a virtual subinterface and moves to subinterface configuration mode

CORP(config-subif)# description
Management VLAN 1 - Native VLAN

Sets the locally significant interface description

CORP(config-subif)# encapsulation
dot1q 1 native

Assigns VLAN 1 to this subinterface. VLAN 1 is the native VLAN. This subinterface uses the 802.1q protocol

CORP(config-subif)# ip address
192.168.1.1 255.255.255.0

Assigns an IP address and netmask

CORP(config-subif)# interface
fastethernet 0/0.10

Creates a virtual subinterface and moves to subinterface configuration mode

CORP(config-subif)# description
Sales VLAN 10

Sets the locally significant interface description

CORP(config-subif)# encapsulation
dot1q 10

Assigns VLAN 10 to this subinterface. This subinterface uses the 802.1q protocol

CORP(config-subif)# ip address
192.168.10.1 255.255.255.0

Assigns an IP address and netmask

CORP(config-subif)# interface
fastethernet 0/0.20

Creates a virtual subinterface and moves to subinterface configuration mode

CORP(config-subif)# description
Engineering VLAN 20

Sets the locally significant interface description

CORP(config-subif)# encapsulation
dot1q 20

Assigns VLAN 20 to this subinterface. This subinterface uses the 802.1q protocol

CORP(config-subif)# ip address
192.168.20.1 255.255.255.0

Assigns an IP address and netmask

CORP(config-subif)# interface
fastethernet 0/0.30

Creates a virtual subinterface and moves to subinterface configuration mode

CORP(config-subif)# description
Marketing VLAN 30

Sets the locally significant interface description

CORP(config-subif)# encapsulation
dot1q 30

Assigns VLAN 30 to this subinterface. This subinterface uses the 802.1q protocol

CORP(config-subif)# ip add
192.168.30.1 255.255.255.0

Assigns an IP address and netmask

CORP(config-subif)# exit

Returns to global configuration mode

CORP(config)# router eigrp 10

Creates EIGRP routing process 10 and moves to router configuration mode

CORP(config-router)# network
192.168.1.0 0.0.0.255

Advertises the 192.168.1.0 network

CORP(config-router)# network
192.168.10.0 0.0.0.255

Advertises the 192.168.10.0 network

CORP(config-router)# network
192.168.20.0 0.0.0.255

Advertises the 192.168.20.0 network

CORP(config-router)# network
192.168.30.0 0.0.0.255

Advertises the 192.168.30.0 network

CORP(config-router)# network
172.31.0.0 0.0.255.255

Advertises the 172.31.0.0 network

CORP(config-router)# network
192.31.7.0 0.0.0.3

Advertises the 192.31.7.0 network

CORP(config-router)# end

Returns to privileged EXEC mode

CORP# copy running-config
startup-config

Saves the configuration in NVRAM

L2Switch2 (Catalyst 2960)

Switch> enable

Moves to privileged EXEC mode

Switch# configure terminal

Moves to global configuration mode

Switch(config)# hostname L2Switch2

Sets the host name

L2Switch2(config)#
no ip domain-lookup

Turns off DNS resolution

L2Switch2(config)# vlan 10

Creates VLAN 10 and enters VLAN configuration mode

L2Switch2(config-vlan)# name Sales

Assigns a name to the VLAN

L2Switch2(config-vlan)# exit

Returns to global configuration mode

L2Switch2(config)# vlan 20

Creates VLAN 20 and enters VLAN configuration mode

L2Switch2(config-vlan)# name
Engineering

Assigns a name to the VLAN

L2Switch2(config-vlan)#
vlan 30

Creates VLAN 30 and enters VLAN configuration mode. Note that you do not have to exit back to global configuration mode to execute this command

L2Switch2(config-vlan)# name
Marketing

Assigns a name to the VLAN

L2Switch2(config-vlan)# exit

Returns to global configuration mode

L2Switch2(config)# interface
range fastethernet 0/2 - 4

Enters interface range configuration mode and allows you to set the same configuration parameters on multiple ports at the same time

L2Switch2(config-if-range)#
switchport mode access

Sets ports 2–4 as access ports

L2Switch2(config-if-range)#
switchport access vlan 10

Assigns ports 2–4 to VLAN 10

L2Switch2(config-if-range)#
interface range fastethernet
0/5 - 8

Enters interface range configuration mode and allows you to set the same configuration parameters on multiple ports at the same time

L2Switch2(config-if-range)#
switchport mode access

Sets ports 5–8 as access ports

L2Switch2(config-if-range)#
switchport access vlan 20

Assigns ports 5–8 to VLAN 20

L2Switch2(config-if-range)#
interface range fastethernet
0/9 - 12

Enters interface range configuration mode and allows you to set the same configuration parameters on multiple ports at the same time

L2Switch2(config-if-range)#
switchport mode access

Sets ports 9–12 as access ports

L2Switch2(config-if-range)#
switchport access vlan 30

Assigns ports 9–12 to VLAN 30

L2Switch2(config-if-range)# exit

Returns to global configuration mode

L2Switch2(config)# interface
fastethernet 0/1

Moves to interface configuration mode

L2Switch2(config)# description
Trunk Link to CORP Router

Sets the locally significant interface description

L2Switch2(config-if)#
switchport mode trunk

Puts the interface into trunking mode and negotiates to convert the link into a trunk link

L2Switch2(config-if)# exit

Returns to global configuration mode

L2Switch2(config)#
interface vlan 1

Creates a virtual interface for VLAN 1 and enters interface configuration mode

L2Switch2(config-if)# ip address
192.168.1.2 255.255.255.0

Assigns an IP address and netmask

L2Switch2(config-if)# no shutdown

Enables the interface

L2Switch2(config-if)# exit

Returns to global configuration mode

L2Switch2(config)# ip
default-gateway 192.168.1.1

Assigns a default gateway address

L2Switch2(config)# exit

Returns to privileged EXEC mode

L2Switch2# copy running-config
startup-config

Saves the configuration in NVRAM

L3Switch1 (Catalyst 3650)

Switch> enable

Moves to privileged EXEC mode

Switch# configure terminal

Moves to global configuration mode

Switch(config)# hostname L3Switch1

Sets the host name

L3Switch1(config)#
no ip domain-lookup

Turns off DNS queries so that spelling mistakes do not slow you down

L3Switch1(config)# vtp mode server

Changes the switch to VTP server mode

L3Switch1(config)# vtp domain
testdomain

Configures the VTP domain name to testdomain

L3Switch1(config)# vlan 10

Creates VLAN 10 and enters VLAN configuration mode

L3Switch1(config-vlan)# name
Accounting

Assigns a name to the VLAN

L3Switch1(config-vlan)# exit

Returns to global configuration mode

L3Switch1(config)# vlan 20

Creates VLAN 20 and enters VLAN configuration mode

L3Switch1(config-vlan)# name
Marketing

Assigns a name to the VLAN

L3Switch1(config-vlan)# exit

Returns to global configuration mode

L3Switch1(config)# interface
gigabitethernet 1/0/1

Moves to interface configuration mode

L3Switch1(config-if)# switchport
trunk encapsulation dot1q

Specifies 802.1Q tagging on the trunk link (only necessary on older model switches like the 3560 and 3750)

L3Switch1(config-if)# switchport
mode trunk

Puts the interface into trunking mode and negotiates to convert the link into a trunk link

L3Switch1(config-if)# exit

Returns to global configuration mode

L3Switch1(config)# ip routing

Enables IP routing on this device

L3Switch1(config)# interface vlan 1

Creates a virtual interface for VLAN 1 and enters interface configuration mode

L3Switch1(config-if)# ip address
172.16.1.1 255.255.255.0

Assigns an IP address and netmask

L3Switch1(config-if)# no shutdown

Enables the interface

L3Switch1(config-if)# interface
vlan 10

Creates a virtual interface for VLAN 10 and enters interface configuration mode

L3Switch1(config-if)# ip address
172.16.10.1 255.255.255.0

Assigns an IP address and mask

L3Switch1(config-if)# no shutdown

Enables the interface

L3Switch1(config-if)# interface
vlan 20

Creates a virtual interface for VLAN 20 and enters interface configuration mode

L3Switch1(config-if)# ip address
172.16.20.1 255.255.255.0

Assigns an IP address and mask

L3Switch1(config-if)# no shutdown

Enables the interface

L3Switch1(config-if)# exit

Returns to global configuration mode

L3Switch1(config)# interface
gigabitethernet 1/0/24

Enters interface configuration mode

L3Switch1(config-if)#
no switchport

Creates a Layer 3 port on the switch

L3Switch1(config-if)# ip address
172.31.1.6 255.255.255.252

Assigns an IP address and netmask

L3Switch1(config-if)# exit

Returns to global configuration mode

L3Switch1(config)# router
eigrp 10

Creates EIGRP routing process 10 and moves to router configuration mode

L3Switch1(config-router)# network
172.16.0.0 0.0.255.255

Advertises the 172.16.0.0 network

L3Switch1(config-router)# network
172.31.0.0 0.0.255.255

Advertises the 172.31.0.0 network

L3Switch1(config-router)# end

Applies changes and returns to privileged EXEC mode

L3Switch1# copy running-config
startup-config

Saves configuration in NVRAM

L2Switch1 (Catalyst 2960)

Switch> enable

Moves to privileged EXEC mode

Switch# configure terminal

Moves to global configuration mode

Switch(config)# hostname L2Switch1

Sets the host name

L2Switch1(config)# no ip
domain-lookup

Turns off DNS queries so that spelling mistakes do not slow you down

L2Switch1(config)# vtp domain
testdomain

Configures the VTP domain name to testdomain

L2Switch1(config)# vtp mode client

Changes the switch to VTP client mode

L2Switch1(config)# interface
range fastethernet 0/1 - 4

Enters interface range configuration mode and allows you to set the same configuration parameters on multiple ports at the same time

L2Switch1(config-if-range)#
switchport mode access

Sets ports 1–4 as access ports

L2Switch1(config-if-range)#
switchport access vlan 10

Assigns ports 1–4 to VLAN 10

L2Switch1(config-if-range)#
interface range fastethernet
0/5 - 8

Enters interface range configuration mode and allows you to set the same configuration parameters on multiple ports at the same time

L2Switch1(config-if-range)#
switchport mode access

Sets ports 5–8 as access ports

L2Switch1(config-if-range)#
switchport access vlan 20

Assigns ports 5–8 to VLAN 20

L2Switch1(config-if-range)# exit

Returns to global configuration mode

L2Switch1(config)# interface
gigabitethernet 0/1

Moves to interface configuration mode

L2Switch1(config-if)# switchport
mode trunk

Puts the interface into trunking mode and negotiates to convert the link into a trunk link

L2Switch1(config-if)# exit

Returns to global configuration mode

L2Switch1(config)# interface
vlan 1

Creates a virtual interface for VLAN 1 and enters interface configuration mode

L2Switch1(config-if)# ip address
172.16.1.2 255.255.255.0

Assigns an IP address and netmask

L2Switch1(config-if)# no shutdown

Enables the interface

L2Switch1(config-if)# exit

Returns to global configuration mode

L2Switch1(config)# ip
default-gateway 172.16.1.1

Assigns the default gateway address

L2Switch1(config)# exit

Returns to privileged EXEC mode

L2Switch1# copy running-config
startup-config

Saves the configuration in NVRAM

5. Configuration Example: IPv6 Inter-VLAN Communication | Next Section Previous Section

Cisco Press Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Cisco Press and its family of brands. I can unsubscribe at any time.

Overview

Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Cisco Press products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information

To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@ciscopress.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information

Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security

Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children

This site is not directed to children under the age of 13.

Marketing

Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information

If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out

Users can always make an informed choice as to whether they should proceed with certain services offered by Cisco Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.ciscopress.com/u.aspx.

Sale of Personal Information

Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents

California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure

Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links

This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact

Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice

We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020