Home > Articles > Cisco Network Technology > General Networking > Configuration of Frame Mode MPLS

Configuration of Frame Mode MPLS

Chapter Description

This chapter covers the background and configuration of frame mode Multiprotocol Label Switching (MPLS), discussing common configurations and features such as Configuring Basic MPLS, MPLS Traffic Engineering, and MPLS Virtual Private Networks.

This chapter covers the background and configuration of frame mode Multiprotocol Label Switching (MPLS). The following common configurations and features are discussed:

  • 10-1: Configuring Basic MPLS—MPLS is a high-performance packet forwarding technology that is based on Layer 2 switching instead of relying only on Layer 3 routing. Routers use labels added between the Layer 2 and Layer 3 headers for forwarding decisions.
  • 10-2: MPLS Traffic Engineering—Service providers can use traffic engineering on MPLS-enabled routers to route a customer's network traffic based on throughput and delay. Tunnels are created for label switch paths (LSP) using the Resource Reservation Protocol (RSVP).
  • 10-3: MPLS Virtual Private Networks (VPN)—MPLS VPNs have separate virtual routing and forwarding (VRF) instances for each customer in addition to a global routing table that is used to reach other routers in the provider network. Each VRF has a 64-bit route distinguisher (RD) to keep each customer's IP subnet separate from other routing and forwarding tables. BGP route target communities are used in exchanging route information between routers.

10-1 Configuring Basic MPLS

Multiprotocol Label Switching (MPLS) is a high-performance packet forwarding technology based on Layer 2 switching instead of Layer 3 routing. Routers are configured for MPLS forward frames based on labels instead of traditional Layer 3 IP unicast routing that performs Layer 3 lookups on the destination address at each hop. MPLS labels are inserted between the Layer 2 and Layer 3 headers and can be pushed (added), popped (removed), swapped, or aggregated (removing the top label and performing a Layer 3 lookup).

  • MPLS is attractive to service providers because of its scalability and features. Providers can scale easier with MPLS than using Asynchronous Transfer Mode (ATM) or Frame Relay permanent virtual circuits (PVC). The traffic engineering features of MPLS enable providers to route traffic not just on a destination address but also on other factors such as bandwidth requirements and quality of service (QoS).
  • A label switch router (LSR) is any router or switch that implements label distribution and can forward packets based on labels. An edge-LSR is any router that performs label imposition (push) or label disposition (pop). An ATM LSR is an ATM switch that can act as an LSR. With ATM LSRs, cell switching is used for the label forwarding table.
  • MPLS-enabled routers communicate with each other using the Label Distribution Protocol (LDP). LSRs discover each other using hello packets, and peer relationships are maintained using keepalives. LSRs share label binding information with other LSRs. The label bindings build a forwarding equivalence class (FEC). A forwarding equivalence class is a group of IP packets forwarded in the same manner, over the same path, with the same forwarding treatment.
  • Routers still rely on Layer 3 routing protocols for determining the path a packet should take. However, routing information, along with VPN, traffic engineering, and QoS information, is sent to the data plane to build a label forwarding information base (LFIB) for optimal forwarding performance.

Configuration

  1. (Required) Enable Cisco Express Forwarding (CEF):
    (global) ip cef [distributed]
          
    CEF must be enabled on all routers running MPLS and on interfaces receiving unlabeled IP packets. Core routers do not perform CEF switching but must have CEF enabled globally to exchange labels. Enter the distributed keyword if your router supports distributed CEF (dCEF). Use dCEF when you want your line cards (for example, VIP cards) to perform the express forwarding so that the route processor (RP) can handle routing protocols.
  2. (Required) Start MPLS packet switching:
    (global and interface) mpls ip
          
    You must enable MPLS forwarding both globally and on the router interfaces for which you want to participate in MPLS forwarding. This command enables label switching of IPv4 packets according to normally routed paths. (Additional configuration is needed to support traffic engineering, QoS, and VPNs.) When this command is entered, Label Distribution Protocol (LDP) hello and keepalives are sent and received on the interfaces enabled for MPLS.
  3. (Optional) Select the distribution protocol either globally or on a particular interface:
    (global) mpls label protcol {ldp | tdp}
    
    -or-
    (interface) mpls label protocol {ldp | tdp | both}
    Starting with Cisco IOS Software Release 12.4(3), the default protocol changed from Cisco Tag Distribution Protocol (TDP) to the IETF LDP. When changing the protocol on an interface, you have the option of enabling both TDP and LDP. LSRs must run the same distribution protocol to establish a peer session and exchange label information.
  4. (Optional) Manually configure the LDP identifier:
    (global) mpls ldp router-id interface [force]
    MPLS-enabled routers identify themselves in LDP messages using an identifier. By default, the identifier is the highest IP address of all loopback interfaces. If there are no loopback interfaces, the router uses the highest IP address of all active interfaces. You can manually configure the LDP identifier with this command. The router then uses whatever IP address is configured on the interface you specify. The IP address entered must be reachable by adjacent LSRs. A common symptom of having an unreachable LDP ID IP address is that the forwarding information base (FIB) is populated, but there is no information in the label information forwarding base (LFIB). By default, a router ID is not changed until the interface currently used for the router ID is shut down, the IP address on that interface changes or is removed, or the router is rebooted. You can use the force keyword to force the router to change the router ID.
  5. (Optional) Enable the distribution of labels associated with the IP default route:
    (global) mpls ip default-route
          
    By default, Cisco routers will not distribute labels for the IP default route. Enter this command to enable dynamic switching of labels for a router's default route.
  6. (Optional) Enable MD5 authentication between peers:
    (global) mpls ldp neighbor ip-address password password-string
    MD5 authentication can be configured to verify TCP communication between two LDP peers. Both peers must be configured to use the same password.
  7. (Optional) Enable the MPLS LDP autoconfiguration feature for OSPF interfaces:
    (router) mpls ldp autoconfig [area area-id]
    Normally, you must enter the mpls ip command both globally and on each interface for which you want to send and receive LDP packets. This process might be time-consuming and prone to human errors when configuring a router with many interfaces. The autoconfiguration feature helps with these issues by automatically enabling LDP on every interface associated with an OSPF or IS-IS instance. Note that you still need to enable LDP globally. When configuring LDP autoconfiguration for OSPF, you can choose to only enable LDP for interfaces belonging to a particular area by entering the area keyword followed by the area number.
  8. (Optional) Enable the MPLS LDP autoconfiguration feature for IS-IS interfaces:
    (router) mpls ldp autoconfig [level-1 | level-2]
    Like autoconfiguration for OSPF, you must first enter the global mpls ip command before you can allow the autoconfiguration feature. Optionally, you can allow autoconfiguration on interfaces configured for level-1 or level-2 routing by entering the level-1 or level-2 keywords, respectively.

Example

Figure 10-1 is used for this example. The three routers are configured for MPLS with manually configured LDP identifiers and MD5 peer authentication. Additionally, RouterB is configured for OSPF autoconfiguration for Area 0, and LDP is disabled on RouterA's FastEthernet0/0 interface.

Figure 10-1

Figure 10-1 Basic MPLS Configuration Example

RouterA
hostname RouterA
!
ip cef
mpls ip
mpls ldp router-id 1.1.1.1
mpls ldp neighbor 2.2.2.2 password C1sc0
!
interface fastethernet0/0
 ip address 172.16.0.1 255.255.0.0
 no mpls ip
!
interface fastethernet0/1
 ip address 172.17.0.1 255.255.0.0
 mpls ip
!
interface loopback 0
 ip address 10.1.1.1 255.255.255.255
!
interface loopback 1
 ip address 1.1.1.1 255.255.255.255
!
router ospf 1
 router-id 10.1.1.1
 network 172.16.0.0 0.0.255.255 area 0
 network 172.17.0.0 0.0.255.255 area 0
 network 10.1.1.1 0.0.0.0 area 0
 network 1.1.1.1 0.0.0.0 area 0


RouterB
hostname RouterB
!
mpls ip
mpls ldp router-id 2.2.2.2
mpls ldp neighbor 1.1.1.1 password C1sc0
mpls ldp neighbor 3.3.3.3 password C1sc0
!
interface fastethernet0/0
 ip address 172.17.0.2 255.255.0.0
!
interface fastethernet0/1
 ip address 172.18.0.1 255.255.0.0
!
interface loopback0
 ip address 10.2.2.2 255.255.255.255
!
interface loopback1
 ip address 2.2.2.2 255.255.255.255
!
router ospf 1
 router-id 10.2.2.2
 network 172.17.0.0 0.0.255.255 area 0
 network 172.18.0.0 0.0.255.255 area 0
 network 10.2.2.2 0.0.0.0 area 0
 network 2.2.2.2 0.0.0.0 area 0
 mpls ldp autoconfig area 0


RouterC
hostname RouterC
!
mpls ip
mpls ldp router-id 3.3.3.3
mpls ldp neighbor 2.2.2.2 password C1sc0
!
interface fastethernet0/0
 ip address 172.18.0.2 255.255.0.0
 mpls ip
!
interface fastethernet0/1
 ip address 172.19.0.1 255.255.0.0
 mpls ip
!
interface loopback0
 ip address 10.3.3.3 255.255.255.255
!
interface loopback1
 ip address 3.3.3.3 255.255.255.255
!
router ospf 1
 router-id 10.3.3.3
 network 172.18.0.0 0.0.255.255 area 0
 network 172.19.0.0 0.0.255.255 area 0
 network 10.3.3.3 0.0.0.0 area 0
 network 3.3.3.3 0.0.0.0 area 0
2. 10-2 MPLS Traffic Engineering | Next Section

Cisco Press Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Cisco Press and its family of brands. I can unsubscribe at any time.

Overview

Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Cisco Press products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information

To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@ciscopress.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information

Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security

Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children

This site is not directed to children under the age of 13.

Marketing

Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information

If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out

Users can always make an informed choice as to whether they should proceed with certain services offered by Cisco Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.ciscopress.com/u.aspx.

Sale of Personal Information

Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents

California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure

Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links

This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact

Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice

We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020