Troubleshooting EIGRP

  • Sample Chapter is provided courtesy of Cisco Press.
  • Date: Jul 26, 2002.

Chapter Description

Learn how to quickly identify and fix the most common causes of EIGRP problems with these debugs, configurations, and useful show commands.

Troubleshooting EIGRP Redistribution Problems

In many instances, a problem occurs when redistributing from another routing protocol into EIGRP. Figure 7-32 shows a flowchart for troubleshooting EIGRP redistribution problem.

Figure 7-32Figure 7-32 Flowchart for Troubleshooting EIGRP Redistribution Problem

Consider the network diagram in Figure 7-33, in which the router is the border router between three routing protocols, RIP, OSPF, and EIGRP.

Figure 7-33Figure 7-33 Network Susceptible to EIGRP Redistribution Problems

Example 7-57 shows the configuration for Router A.

Example 7-57 Configuration for Router A in Figure 7-33

Router A# interface ethernet 0
  ip address 172.16.1.1 255.255.255.0
interface ethernet 1
  ip address 172.16.2.1 255.255.255.0
interface serial 0
  ip address 172.16.3.1 255.255.255.0
router ospf 1
  network 172.16.0.0 0.0.255.255 area 0
router rip
  network 172.16.0.0
  passive-interface ethernet 1 
    
router eigrp 1
  network 172.16.0.0
  redistribute rip
  default-metric 10000 100 255 1 1500

Router A wants to redistribute all the routes in the RIP domain into the EIGRP domain. The problem is that the network 150.150.0.0/16 is not getting redistributed into the EIGRP domain.

Referring to Figure 7-33, you can see that the 150.150.0.0/16 network is present in the RIP domain and the OSPF domain. Before the route is getting redistributed into EIGRP, the route must be in the EIGRP topology table first. Look at the EIGRP topology table on Router A for the 150.150.0.0/16 network in Example 7-58.

Example 7-58 EIGRP Topology Table for 150.150.0.0/16

Router A# show ip eigrp topology 150.150.0.0 255.255.0.0

% Route not in topology table

As this output shows, the route 150.150.0.0/16 is not even in the EIGRP topology table. Example 7-59 shows the routing table for the 150.150.0.0/16 network.

Example 7-59 Routing Table for 150.150.0.0/16

Router A# show ip route 150.150.0.0 255.255.0.0

Routing entry for 150.150.0.0/16
 Known via "
OSPF 1
", distance 110, metric 186
 Redistributing via OSPF 1
 Last update from 172.16.2.2 on Ethernet 1
 Routing Descriptor Blocks:
 *  172.16.2.2, from 172.16.2.2, 00:10:23 ago, via Ethernet 1
 Route metric is 186, traffic share count is 1

The output in Example 7-59 shows that the 150.150.0.0/16 route is showing up as an OSPF route, not a RIP route. This is why the route is not getting redistributed into EIGRP. Before RIP routes are redistributed into EIGRP, the router looks at the routing table and redistributes all the RIP routes into EIGRP. As Example 7-59 shows, the router hears the update for the 150.150.0.0/16 route from both OSPF and RIP. The router installs the OSPF route because OSPF has a lower administrative distance than RIP. Therefore, if the route is showing up as an OSPF route, the router will not redistribute this route into EIGRP. In other words, the router will redistribute only RIP routes that are showing in the routing table into the EIGRP domain.

The resolve this problem, you must make Router A install the RIP route instead of the OSPF route. One way to do this is to configure a distribute list under OSPF to not install the 150.150.0.0/16 route, as demonstrated in Example 7-60.

Example 7-60 Configuring a Distribute List Under OSPF to Not Install the 150.150.0.0/16 Route

router OSPF 1
  network 172.16.0.0 0.0.255.255 area 0
distribute-list 1 out
access-list 1 deny 150.150.0.0 0.0.255.255
access-list 1 permit any

With the distribute list in place, Router A's routing table for the 150.150.0.0/16 will now show the results in Example 7-61.

Example 7-61 Routing Table for 150.150.0.0/16 After Configuring the Distribute List in Example 7-60

Router A# show ip route 150.150.0.0 255.255.0.0

Routing entry for 150.150.0.0/16
 Known via 
"RIP"
, distance 120, metric 4
 Redistributing via RIP
 Last update from 172.16.3.2 on Serial 0
 Routing Descriptor Blocks:
 *   172.16.3.2, from 172.16.3.2, 00:00:23 ago, via Serial 0
 Route metric is 4, traffic share count is 1

Because the routing table in Router A shows the 150.150.0.0/16 route as a RIP route, redistribution into EIGRP takes place and the EIGRP topology table in Router A now shows the results in Example 7-62.

Example 7-62 EIGRP Topology Table for 150.150.0.0/16 After Configuring the Distribute List in Example 7-60

Router A# show ip eigrp topology 150.150.0.0 255.255.0.0
IP-EIGRP topology entry for 150.150.0.0/16
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
Routing Descriptor Blocks:
0.0.0.0, from RIP, Send flag is 0x0
Composite metric is (281600/0), Route is External
  Vector metric:
  Minimum bandwidth is 10000 Kbit
  Total delay is 1000 microseconds
  Reliability is 255/255
  Load is 1/255
  Minimum MTU is 1500
  Hop count is 0
  External data:
  Originating router is 172.16.3.1 (this system)
  AS number of routes is 0
  External protocol is RIP, external metric is 4
  Administrator tag is 0

The topology table shows that route 150.150.0.0/16 is getting redistributed into EIGRP with the external routing protocol being RIP. The originating router is 172.16.3.1, which is Router A.

Consider another case in which the network setup is shown in Figure 7-34. The routes in the OSPF domain fails to be redistributed into the EIGRP domain.

Figure 7-34Figure 7-34 Network Setup of Case Study for OSPF to EIGRP Route Redistribution Problem

From the setup shown in Figure 7-34, Router B is redistributing from OSPF to EIGRP. The 10.0.0.0/8 network comes from the OSPF domain and is being redistributed into EIGRP domain by Router B. However, Router A never sees the 10.0.0.0/8 route in its routing table. Example 7-63 shows the configuration of Router A and Router B, and Example 7-64 shows the routing table of 10.0.0.0/8 route in Router A and Router B.

Example 7-63 Configurations for Routers A and B for Network Setup in Figure 7-34

Router A# interface ethernet 0
  ip address 172.16.3.1 255.255.255.0
interface serial 0
  ip address 172.16.1.1 255.255.255.0
router eigrp 1
  network 172.16.0.0

Router B# interface ethernet 0
  ip address 172.16.2.1 255.255.255.0
interface serial 0
  ip address 172.16.1.2 255.255.255.0
router ospf 1
  network 172.16.0.0 0.0.255.255 area 0
router eigrp 1
  network 172.16.0.0
  redistribute ospf 1

Example 7-64 Routing Table and EIGRP Topology Table for 10.0.0.0/8 Route in Routers A and B

Router_A#show ip route 10.0.0.0 255.0.0.0
% Network not in table

Router_A# show ip eigrp topology 10.0.0.0 255.0.0.0
% Route not in topology table
Router_B# show ip route 10.0.0.0 255.0.0.0
Routing entry for 10.0.0.0/8
 Known via "OSPF 1", distance 110, metric 206
 Redistributing via OSPF 1
 Last update from 172.16.2.2 on Ethernet 0
 Routing Descriptor Blocks:
 *  172.16.2.2, from 172.16.2.2, 00:18:13 ago, via Ethernet 0
 Route metric is 206, traffic share count is 1

Router_B# show ip eigrp topology 10.0.0.0 255.0.0.0
% Route not in topology table

From the output of Example 7-64, notice that Router B has the 10.0.0.0/24 route in its routing table as an OSPF route, but Router A doesn't have the routing entry for 10.0.0.0/8. Also, the EIGRP topology table on Router B doesn't even have the entry for the 10.0.0.0/8 route. You can conclude from this that the OSPF to EIGRP redistribution in Router B is not working.

By looking over the configuration in Router B, you notice that although the redistribute ospf 1 command is configured under EIGRP, there is no configuration of the default-metric command. When redistributing between different routing protocols, the default-metric com-mand must be configured. When one routing protocol is being redistributed into another, the router doesn't have a way to translate the routing metric from one routing protocol into another. The default-metric command is used so that the network administrator can manually initialize the routing metric during route redistribution. The fix for this problem: Configure a default metric under EIGRP in Router B. Example 7-65 shows the corrected configuration of Router B.

Example 7-65Å@Corrected Configurations of Router B to Fix the Redistribution Problem Shown in Figure 7-34

Router B# interface ethernet 0
  ip address 172.16.2.1 255.255.255.0
interface serial 0
  ip address 172.16.1.2 255.255.255.0
router ospf 1
  network 172.16.0.0 0.0.255.255 area 0
router eigrp 1
  network 172.16.0.0
  redistribute ospf 1
  default-metric 10000 100 255 1 1500

From Example 7-65, the default metric configured is default-metric 10000 100 255 1 1500. 10000 is the bandwidth in kilobits per second. 100 is the interface delay in unit of 10 micro-seconds. 255 is interface reliability, where 255 represents 100 percent reliable. 1 is interface load, where 255 represents 100 percent load. The last number, 1500, is the MTU of the inter-face. Because the 10.0.0.0/8 route comes from the Ethernet interface of Router B, we are setting the default metrics that matches the Ethernet interface—namely, bandwidth of 10,000 kbps, delay of 1000 ms, 100 percent reliability, 1/255 of interface load, and an MTU of 1500 bytes. Keep in mind that the router will accept any values for the default metric setting. The router will even accept default metric value of 1 1 1 1 1. However, using the default metric value that best matches the network topology will allow the router to make a better routing decision. Now with the correct configuration in place in Router B, Example 7-66 shows the routing table in Router A for the 10.0.0.0/8 route.

Example 7-66 Routing Table on Router A and EIGRP Topology Table in Router B for the 10.0.0.0/8 Route to Verify the Fix

Router_A#show ip route 10.0.0.0
Routing entry for 10.0.0.0/8
 
Known via "eigrp 1", distance 170, metric 2195456, 
type external
 Redistributing via eigrp 1
Last update from 172.16.1.2 on Serial0, 00:16:37 ago
 Routing Descriptor Blocks:
*172.16.1.2, from 172.16.1.2, 00:16:37 ago, via Serial0
   Route metric is 2195456, traffic share count is 1
   Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
   Reliability 255/255, minimum MTU 1500 bytes
   Loading 1/255, Hops 1
Router B# show ip eigrp topology 10.0.0.0 255.0.0.0
IP-EIGRP topology entry for 10.0.0.0/8
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
Routing Descriptor Blocks:
0.0.0.0, from Redistributed, Send flag is 0x0
Composite metric is (281600/0), Route is External
  Vector metric:
  Minimum bandwidth is 10000 Kbit
  Total delay is 1000 microseconds
  Reliability is 255/255
  Load is 1/255
  Minimum MTU is 1500
  Hop count is 0
  External data:
  Originating router is 172.16.2.1 (this system)
  AS number of routes is 1
  External protocol is OSPF, external metric is 206
  Administrator tag is 0

From Example 7-66, you can see that Router A has the 10.0.0.0/8 route as EIGRP external route, whereas Router B has the EIGRP topology entry for the 10.0.0.0/8 route. The 10.0.0.0/8 route now has been successfully being redistributed from OSPF into EIGRP.

7. Troubleshooting EIGRP Dial Backup Problem | Next Section Previous Section

Cisco Press Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Cisco Press and its family of brands. I can unsubscribe at any time.

Overview

Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Cisco Press products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information

To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@ciscopress.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information

Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security

Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children

This site is not directed to children under the age of 13.

Marketing

Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information

If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out

Users can always make an informed choice as to whether they should proceed with certain services offered by Cisco Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.ciscopress.com/u.aspx.

Sale of Personal Information

Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents

California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure

Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links

This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact

Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice

We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020