Home > Articles > Cisco Network Technology > General Networking > Exploring QoS in Catalyst

Exploring QoS in Catalyst

  • Sample Chapter is provided courtesy of Cisco Press.
  • Date: Jul 4, 2003.

Chapter Description

Discover the workings of the the various platform QoS features available across the Cisco Catalyst product family. You will gain full understanding of each Catalyst platform's supported QoS features and be able to configure various Catalyst families of switches.

QoS Support on the Catalyst 2900XL and 3500XL

Specific models of the Catalyst 2900XL and 3500XL support QoS classification and congestion management. Ingress packet CoS values and configured port priorities exclusively determine classification of ingress frames for placement into either a low-priority or high-priority global transmit queue. The two global transmit queues with priority scheduling create the congestion management mechanism. The following sections discuss these QoS features with detailed overviews, configuration guidelines, and examples.

Catalyst 2900XL Product Family Delineation

QoS support on the Catalyst 2900XL and 3500XL platforms is software and model dependent. For the 2900XL, the original-edition models do not support QoS features, including the uplink modules for the Catalyst 2916M. All standard- and enterprise-edition models do support QoS features. Table 3-6 indicates which 2900XL models support QoS features. All models of the 3500XL support QoS features. In addition, the Catalyst 3524XL-PWR-XL and the 3548XL support CoS reclassification. This QoS feature is not available on other 3500XL platforms.

Table 3-6 QoS Support by Model of 2900XL

Catalyst 2900XL/3500XL Model

Description

QoS Support

WS-C2908-XL

8-port 10/100BASE-TX switch

No

WS-C2912-XL-A/EN

12-port 10/100BASE-TX switch

Yes

WS-C2912MF-XL

12-port 100BASE-FX switch

Yes

WS-C2916M-XL

16-port 10/100BASE-TX switch + 2 uplink slots

No

WS-C2924-XL

24-port 10/100BASE-TX switch

No

WS-C2924C-XL

22-port 10/100BASE-TX + 2-port 100BASE-FX switch

No

WS-C2924-XL-A/EN

24-port 10/100BASE-TX switch

Yes

WS-C2924C-XL-A/EN

22-port 10/100BASE-TX switch + 2-port 100BASE-FX switch

Yes

WS-C2924M-XL-A/EN

24-port 10/100BASE-TX switch + 2 uplink slots

Yes

WS-C2924M-XL-EN-DC

24-port 10/100BASE-TX switch + 2 uplink slots (DC power)

Yes


Catalyst 2900XL and 3500XL QoS Architectural Overview

The Catalyst 2900XL and 3500XL switches are limited to QoS features that suit access layer switches. These features include classification, marking, and congestion management via the use of output scheduling. Because of these features, the 2900XL and 3500XL fit well into an end-to-end QoS design with core switches. Figure 3-2 shows a sample network deploying access layer QoS features with comprehensive QoS features in the core.

Figure 02Figure 3-2 Network Topology Using Catalyst 3524XLs


Figure 3-3 shows the basic QoS architecture model for the Catalyst 2900XL and 3500XL discussed in the following sections.

Figure 03Figure 3-3 Basic QoS Architecture for the Catalyst 2900XLs and 3500XLs Switches


Software Requirements

For QoS feature support, the 2900XL and 3500XL require Cisco IOS Software Release 12.0(5)XP or higher. The 3524-PWR-XL and the 3548XL require 12.0(5)XU or higher for the reclassification of class of CoS values in frames.

Input Scheduling

The Catalyst 2900XL and 3500XL do not perform input scheduling as ingress packets are immediately copied to a global, shared memory buffer. As long as the packet-forwarding rate of the switch is not exceeded, input congestion is not critical to implementing QoS. The packet-forwarding rates of the Catalyst 2900XL and the Catalyst 3500XL are 1.6 Gbps and 5.0 Gbps, respectively.

Classification/Reclassification

The Catalyst 2900XL and 3500XL switches both support classification of untagged frames. Two models of the Catalyst 3500XL switch, the Catalyst 3524-PWR-XL and the Catalyst 3548XL switches, support marking of ingress tagged frames. Classification and marking is configurable only on a per-port basis, and each port may be configured with a unique CoS value to be classified.

To configure a Catalyst 2900XL and 3500XL for classification or marking of frames, use the following interface command:

switchport priority {default default-priority-id | extend {cos value | none |
trust} | override}
  • The default-priority-id parameter is the CoS value to be assigned to untagged ingress frames.

  • The extend option is to configure the 802.1p trust configuration of the connected appliance on the P1 port of the IP Phone. For example, a Cisco IP Phone can be configured to trust or reclassify frames received on its P1 port.

  • The override option is used to mark tagged frames with the default-priority-id. Only the Catalyst 3524-PWR-XL and the Catalyst 3548XL switches support this marking feature.

Example 3-1 shows a Catalyst 3548XL switch port configured to classify untagged frames with a CoS value of 2.

Example 3-1 Catalyst 3548XL Switch Port Configured to Classify Untagged Frames

Switch#show running-config
Building configuration...

Current configuration:
(text deleted)
!
interface FastEthernet0/48
 switchport priority default 2
 spanning-tree portfast
 (text deleted)
end

Example 3-2 shows a Catalyst 3524-PWR-XL switch port configured for a voice VLAN. In Cisco IOS Software Release 12.0.x, voice VLAN ports must be configured as trunk ports.

Example 3-2 Catalyst 3548XL Switch Port for Voice VLANs

Switch#show running-config
Building configuration...

Current configuration:
(text deleted)
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
 switchport voice vlan 70
 spanning-tree portfast
(text deleted)
end

NOTE

The Catalyst 2900XL and 3500XL software configuration for voice VLANs differs from the Catalyst switches that run Cisco IOS Software Release 12.1, such as the Catalyst 4000 Supervisor III and IV. Cisco IOS Software Release 12.1 does not require voice VLAN ports to be configured as trunks.

Congestion Management

The 2900XL and 3500XL switches use a shared memory buffer system because each individual port does not have its own output queue. This shared memory buffer is divided into two global transmit queues. Each ingress packet is placed into one of two global transmit queues based on CoS value for tagged frames and CoS classification for untagged frames. One of the transmit queues is designated for packets with a CoS value of 0 to 3, and the other transmit queue is reserved for packets with a CoS value of 4 to 7. The queues use a 100-percent threshold value. These queues are not configurable for different CoS values or thresholds. This queue scheme creates a logical high-priority and low-priority queuing mechanism. Priority scheduling is applied such that the high-priority queue is consistently serviced before the low-priority queue. The use of two global transmit queues based on CoS value is default behavior and cannot be altered. As a result, no global configuration is required to enable QoS output scheduling.

NOTE

Untagged packets that are classified with a CoS value transmitted on trunk ports are appropriately tagged with an 802.1q header with the respective CoS. For packets transmitted on nontrunk ports, the untagged classification only determines which queue the frame is placed in for egress transmission.

Case Study: Classification and Output Scheduling on Cisco Catalyst 3500XL Switches

To demonstrate classification and output scheduling on the Catalyst 3500XL series, a Catalyst 3524-PWR-XL was set up with two Cisco 7960 IP Phones, a Call Manager, and a traffic generator connected to three Fast Ethernet ports and a Gigabit Ethernet port, respectively. Figure 3-4 shows this topology. Two trials were conducted taking voice quality statistical measurements from each IP Phone based on a 1-minute, G7.11 voice call between IP Phone 1 and 2. To create traffic congestion, the traffic generator attached to Gigabit Ethernet port was sending multicast at line rate with a CoS value of 0. The multicast traffic was flooded to all ports, including the Fast Ethernet IP Phones, causing output congestion.

Figure 04Figure 3-4 Catalyst 3500XL Case Study Network Diagram

The Catalyst 3524XL switch was running software version 12.0(5)WC5 for the trial. The configuration only included voice VLANs on the Cisco IP Phone ports. The remaining port configuration of the switch was default. Example 3-3 shows the relevant configuration.

Example 3-3 Catalyst 3548XL Switch Port Configuration for Case Study

Switch#show running-config
Building configuration...

Current configuration:
(text deleted)

interface FastEthernet0/1
 switchport access vlan 70
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
 switchport voice vlan 70
 spanning-tree portfast
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 2
 switchport mode trunk
 switchport voice vlan 70
 spanning-tree portfast
!
(text deleted)

interface GigabitEthernet0/1
 switchport access vlan 70
(text deleted)
end

The variant in the two trials was the CoS value placed on the telephony frames between the IP Phones. With a CoS value of 0, the telephony stream was treated with a low priority (the same priority as the multicast traffic). With a CoS value of 5, the telephony stream was treated with a high priority. Table 3-7 summarizes the number of frames transmitted and lost as well as jitter from each trial.

Table 3-7 QoS Trial Results on Catalyst 3524-PWR-XL

Trial

Total Frames Transmitted (Phone 1/2)

No. of Receive Lost Frames (Phone 1/2)

Maximum Recorded Jitter (Phone1/2)

CoS = 0 on voice stream

3100/3110

1551/1549

51/49 ms

CoS = 5 on voice stream

3104/3106

0/0

51/49 ms


As indicated in Table 3-7, the Catalyst 3524XL did not drop a single frame due to output congestion on the IP Phone ports for packets with a CoS value of 5. Similar results are achievable with multiple Cisco IP Phones in a campus network using the Catalyst 2900XL and 3500XL. The jitter did not vary between the trials because all Catalyst switches drop frames under congestion and only buffer a few frames. The maximum recorded jitter is around 50 ms, which is above the recommended 30 ms for Voice over IP (VoIP). Only the first few frames of the IP flow recorded jitter near 50 ms.

Summary

The Catalyst 2900XL and 3500XL suit basic QoS needs for an access layer switch. If additional features such as policing and classification based on DSCP are required, network designers should consider the Catalyst 2950 and 3550 switches for use as an access layer switch. You can summarize QoS feature support on the Catalyst 2900XL and 3500XL switches as follows:

  • No support for input scheduling.

  • Classification based on CoS only; no support for classification based on IP precedence or DSCP.

  • Two global queues for high-priority and low-priority traffic.

  • No configurable CoS mapping to queues or queue threshold.

  • Ports are trusted by default.

  • Untagged frames are mapped to high-priority or low-priority queues based on configured classification CoS value.

  • The Catalyst 3548XL and 3524-PWR-XL support reclassification of tagged frames.

4. QoS Support on the Catalyst 4000 CatOS Family of Switches | Next Section Previous Section

Cisco Press Promotional Mailings & Special Offers

I would like to receive exclusive offers and hear about products from Cisco Press and its family of brands. I can unsubscribe at any time.

Overview

Pearson Education, Inc., 221 River Street, Hoboken, New Jersey 07030, (Pearson) presents this site to provide information about Cisco Press products and services that can be purchased through this site.

This privacy notice provides an overview of our commitment to privacy and describes how we collect, protect, use and share personal information collected through this site. Please note that other Pearson websites and online products and services have their own separate privacy policies.

Collection and Use of Information

To conduct business and deliver products and services, Pearson collects and uses personal information in several ways in connection with this site, including:

Questions and Inquiries

For inquiries and questions, we collect the inquiry or question, together with name, contact details (email address, phone number and mailing address) and any other additional information voluntarily submitted to us through a Contact Us form or an email. We use this information to address the inquiry and respond to the question.

Online Store

For orders and purchases placed through our online store on this site, we collect order details, name, institution name and address (if applicable), email address, phone number, shipping and billing addresses, credit/debit card information, shipping options and any instructions. We use this information to complete transactions, fulfill orders, communicate with individuals placing orders or visiting the online store, and for related purposes.

Surveys

Pearson may offer opportunities to provide feedback or participate in surveys, including surveys evaluating Pearson products, services or sites. Participation is voluntary. Pearson collects information requested in the survey questions and uses the information to evaluate, support, maintain and improve products, services or sites; develop new products and services; conduct educational research; and for other purposes specified in the survey.

Contests and Drawings

Occasionally, we may sponsor a contest or drawing. Participation is optional. Pearson collects name, contact information and other information specified on the entry form for the contest or drawing to conduct the contest or drawing. Pearson may collect additional personal information from the winners of a contest or drawing in order to award the prize and for tax reporting purposes, as required by law.

Newsletters

If you have elected to receive email newsletters or promotional mailings and special offers but want to unsubscribe, simply email information@ciscopress.com.

Service Announcements

On rare occasions it is necessary to send out a strictly service related announcement. For instance, if our service is temporarily suspended for maintenance we might send users an email. Generally, users may not opt-out of these communications, though they can deactivate their account information. However, these communications are not promotional in nature.

Customer Service

We communicate with users on a regular basis to provide requested services and in regard to issues relating to their account we reply via email or phone in accordance with the users' wishes when a user submits their information through our Contact Us form.

Other Collection and Use of Information

Application and System Logs

Pearson automatically collects log data to help ensure the delivery, availability and security of this site. Log data may include technical information about how a user or visitor connected to this site, such as browser type, type of computer/device, operating system, internet service provider and IP address. We use this information for support purposes and to monitor the health of the site, identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents and appropriately scale computing resources.

Web Analytics

Pearson may use third party web trend analytical services, including Google Analytics, to collect visitor information, such as IP addresses, browser types, referring pages, pages visited and time spent on a particular site. While these analytical services collect and report information on an anonymous basis, they may use cookies to gather web trend information. The information gathered may enable Pearson (but not the third party web trend services) to link information with application and system log data. Pearson uses this information for system administration and to identify problems, improve service, detect unauthorized access and fraudulent activity, prevent and respond to security incidents, appropriately scale computing resources and otherwise support and deliver this site and its services.

Cookies and Related Technologies

This site uses cookies and similar technologies to personalize content, measure traffic patterns, control security, track use and access of information on this site, and provide interest-based messages and advertising. Users can manage and block the use of cookies through their browser. Disabling or blocking certain cookies may limit the functionality of this site.

Do Not Track

This site currently does not respond to Do Not Track signals.

Security

Pearson uses appropriate physical, administrative and technical security measures to protect personal information from unauthorized access, use and disclosure.

Children

This site is not directed to children under the age of 13.

Marketing

Pearson may send or direct marketing communications to users, provided that

  • Pearson will not use personal information collected or processed as a K-12 school service provider for the purpose of directed or targeted advertising.
  • Such marketing is consistent with applicable law and Pearson's legal obligations.
  • Pearson will not knowingly direct or send marketing communications to an individual who has expressed a preference not to receive marketing.
  • Where required by applicable law, express or implied consent to marketing exists and has not been withdrawn.

Pearson may provide personal information to a third party service provider on a restricted basis to provide marketing solely on behalf of Pearson or an affiliate or customer for whom Pearson is a service provider. Marketing preferences may be changed at any time.

Correcting/Updating Personal Information

If a user's personally identifiable information changes (such as your postal address or email address), we provide a way to correct or update that user's personal data provided to us. This can be done on the Account page. If a user no longer desires our service and desires to delete his or her account, please contact us at customer-service@informit.com and we will process the deletion of a user's account.

Choice/Opt-out

Users can always make an informed choice as to whether they should proceed with certain services offered by Cisco Press. If you choose to remove yourself from our mailing list(s) simply visit the following page and uncheck any communication you no longer want to receive: www.ciscopress.com/u.aspx.

Sale of Personal Information

Pearson does not rent or sell personal information in exchange for any payment of money.

While Pearson does not sell personal information, as defined in Nevada law, Nevada residents may email a request for no sale of their personal information to NevadaDesignatedRequest@pearson.com.

Supplemental Privacy Statement for California Residents

California residents should read our Supplemental privacy statement for California residents in conjunction with this Privacy Notice. The Supplemental privacy statement for California residents explains Pearson's commitment to comply with California law and applies to personal information of California residents collected in connection with this site and the Services.

Sharing and Disclosure

Pearson may disclose personal information, as follows:

  • As required by law.
  • With the consent of the individual (or their parent, if the individual is a minor)
  • In response to a subpoena, court order or legal process, to the extent permitted or required by law
  • To protect the security and safety of individuals, data, assets and systems, consistent with applicable law
  • In connection the sale, joint venture or other transfer of some or all of its company or assets, subject to the provisions of this Privacy Notice
  • To investigate or address actual or suspected fraud or other illegal activities
  • To exercise its legal rights, including enforcement of the Terms of Use for this site or another contract
  • To affiliated Pearson companies and other companies and organizations who perform work for Pearson and are obligated to protect the privacy of personal information consistent with this Privacy Notice
  • To a school, organization, company or government agency, where Pearson collects or processes the personal information in a school setting or on behalf of such organization, company or government agency.

Links

This web site contains links to other sites. Please be aware that we are not responsible for the privacy practices of such other sites. We encourage our users to be aware when they leave our site and to read the privacy statements of each and every web site that collects Personal Information. This privacy statement applies solely to information collected by this web site.

Requests and Contact

Please contact us about this Privacy Notice or if you have any requests or questions relating to the privacy of your personal information.

Changes to this Privacy Notice

We may revise this Privacy Notice through an updated posting. We will identify the effective date of the revision in the posting. Often, updates are made to provide greater clarity or to comply with changes in regulatory requirements. If the updates involve material changes to the collection, protection, use or disclosure of Personal Information, Pearson will provide notice of the change through a conspicuous notice on this site or other appropriate way. Continued use of the site after the effective date of a posted revision evidences acceptance. Please contact us if you have questions or concerns about the Privacy Notice or any objection to any revisions.

Last Update: November 17, 2020